Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Removed Amazon and Ebay search engines keeps coming back since firefox 80

  • 6 trả lời
  • 1 gặp vấn đề này
  • 13 lượt xem
  • Trả lời mới nhất được viết bởi dfrank1

more options

Hello,

I had custom search engines set in search.json/searchplugins configuration file. It worked perfectly since firefox 80. Now, Amazon and eBay keeps adding themselves as search engines.

Anyone know how to remove them properly once and for all ?

Giải pháp được chọn

I had to remove the entire profile. I guess this is a bug because now it works well.

I find having to reset profile every now and then very annoying. This kind of maintenance should be entirely automated. Firefox profiles are a mess.

Thanks for your help.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (6)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Amazon or eBay “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

Hữu ích?

more options

Hello, thanks for your answer but I don't have any search engine extensions installed, neither within firefox neither within my OS.

I suspect the search engines always coming back are the defaults. My custom search engines used to work properly, now they don't even appear.

Do you have any documentation on how to setup custom search engines on firefox 80+, so I can do it again the right way ?

Hữu ích?

more options

My instructions are to check the Add-ons Manager. Not the search engines.

Hữu ích?

more options

Depending on your region, Amazon and eBay may be built-in default search engines.

Sometimes when Firefox updates, users report it restores one or more "removed" search engines. It may be simpler to remove their check mark in the left column of the "One-Click Search Engines" box instead of removing them and having them come back.

Also, the search.json file changed to the compressed search.json.mozlz4 file some time ago. Are you decompressing it to edit it manually?

Hữu ích?

more options

OK, thanks for the tips. I would like to automate that, any idea if this is directly editable via about:config?

Also, on search.json, I guess it was deprecated for a while and firefox is now only using search.json.mozlz4. That’s probably the core of my issue, I'll try update it and post my result here. Thanks again.

Hữu ích?

more options

Giải pháp được chọn

I had to remove the entire profile. I guess this is a bug because now it works well.

I find having to reset profile every now and then very annoying. This kind of maintenance should be entirely automated. Firefox profiles are a mess.

Thanks for your help.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.