Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Are there any tricks to getting a Chrome URL page as the new tab?

  • 8 trả lời
  • 1 gặp vấn đề này
  • 3 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

The one and only website that I want as my new tab is a bit laggy and takes a while to load, probably because of CloudFlare.

And I'd like to have a huge page to see all of my bookmarks in, to make it easier to organize my bookmarks. Instead of using the bookmarks sidebar or the Library window.

So I thought why not combine the two things that I want? Make my new tab open up to the Chrome bookmarks page, and then if I want that laggy website it can be one of the top bookmarks listed. Or if I want to organize and see my other bookmarks instead, I can just ignore that top bookmark and focus on the other bookmarks.

Well my New Tab URL won't let me and it is a Firefox restriction so he couldn't add the feature even if he wanted to.

But surely there is a trick or workaround that might not involve extensions?

If so, please let me know.

I want chrome://browser/content/places/bookmarksSidebar.xhtml as my new tab page.

The extension was changing it to http://chrome://browser/content/places/bookmarksSidebar.xhtml which broke it.

Được chỉnh sửa bởi gaveitatry vào

Giải pháp được chọn

jscher2000 said

I believe add-ons are limited to http: and https: addresses. There is a trick involving a special kind of startup file called an Autoconfig file. (There actually are two files involved in making it work.) You can see the rough outlines of the approach in this thread: https://support.mozilla.org/en-US/questions/1251199#answer-1199709 That code might need to be updated for Firefox 76: https://support.mozilla.org/questions/1283835


Okay, did some digging around. Found a good website that explained the location. Then I looked for similar location in Firefox Portable.


autoconfig.cfg goes here:

FirefoxPortable > App > firefox64


autoconfig.js goes here:

FirefoxPortable > App > defaults > pref


And it works!!!! Thank you so much jscher!!!! I'll try to remember the new workaround when 76.0 goes out.


ALL CREDIT AND APPRECIATION GOES TO JSCHER2000!!!

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (8)

more options

I believe add-ons are limited to http: and https: addresses.

There is a trick involving a special kind of startup file called an Autoconfig file. (There actually are two files involved in making it work.)

You can see the rough outlines of the approach in this thread:

https://support.mozilla.org/en-US/questions/1251199#answer-1199709

That code might need to be updated for Firefox 76:

https://support.mozilla.org/questions/1283835

Hữu ích?

more options

(snip)

Được chỉnh sửa bởi gaveitatry vào

Hữu ích?

more options

jscher2000 said

I believe add-ons are limited to http: and https: addresses. There is a trick involving a special kind of startup file called an Autoconfig file. (There actually are two files involved in making it work.) You can see the rough outlines of the approach in this thread: https://support.mozilla.org/en-US/questions/1251199#answer-1199709 That code might need to be updated for Firefox 76: https://support.mozilla.org/questions/1283835


Thanks for the reply jscher2000. I want to give this a try, but I am using Firefox Portable and I'm not sure where those two autoconfig files go.

So far, I've tried

FirefoxPortable > Data > profile

FirefoxPortable > Data > profile > chrome

FirefoxPortable > App > firefox64

FirefoxPortable > App > firefox64 > browser.

Được chỉnh sửa bởi gaveitatry vào

Hữu ích?

more options

Giải pháp được chọn

jscher2000 said

I believe add-ons are limited to http: and https: addresses. There is a trick involving a special kind of startup file called an Autoconfig file. (There actually are two files involved in making it work.) You can see the rough outlines of the approach in this thread: https://support.mozilla.org/en-US/questions/1251199#answer-1199709 That code might need to be updated for Firefox 76: https://support.mozilla.org/questions/1283835


Okay, did some digging around. Found a good website that explained the location. Then I looked for similar location in Firefox Portable.


autoconfig.cfg goes here:

FirefoxPortable > App > firefox64


autoconfig.js goes here:

FirefoxPortable > App > defaults > pref


And it works!!!! Thank you so much jscher!!!! I'll try to remember the new workaround when 76.0 goes out.


ALL CREDIT AND APPRECIATION GOES TO JSCHER2000!!!

Được chỉnh sửa bởi gaveitatry vào

Hữu ích?

more options

Hi gaveitatry, for the first file, can you find this folder:

[portable]\App\Firefox\defaults\pref

That seems like the equivalent of:

C:\Program Files\Mozilla Firefox\defaults\pref

The second file usually goes into the same folder as firefox.exe.

I think it's worth asking on the Portable forum if you don't get a solution here:

https://portableapps.com/forums/support/firefox_portable

Hữu ích?

more options

Sorry, when I say "the first file" I mean the one that points to the file with the actual code in it.

Ref. Customizing Firefox Using AutoConfig

Hữu ích?

more options

Actually, UPDATE:

I thought that this was the solution, but I ran into some problems. If I restart Firefox and then open up the new tab, it does go to the Chrome bookmarks page. It will let me drag bookmarks around too. But if I try to create a new bookmark there, it won't let me. And trying to create a new bookmark there will kinda break the page. It's also annoying because as soon as the new tab opens, the cursor is in the URL bar. On other websites, I actually prefer auto focus in URL bar. But not on the Chromes bookmarks page. So I guess I'll go back to just using a regular website for the new tab URL.

But maybe I'll try this again some other time, especially if I decide on another page besides Chrome bookmarks. In the future, I hope I figure out how to set the new tab title too.

Anyway, thank you.

EDIT: Turns out, it's a problem with the Chrome bookmarks page and nothing to do with this new tab URL workaround.

Được chỉnh sửa bởi gaveitatry vào

Hữu ích?

more options

Yes, the bookmarks sidebar page doesn't have full functionality outside of the sidebar.

There is at least one extension that puts your bookmarks in the new tab, i.e., using the normal API for extensions to access bookmarks. I can't recall the name.

Được chỉnh sửa bởi jscher2000 vào

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.