Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

[Firefox Quantum] Rendering bug when scrolling in portrait

  • 4 trả lời
  • 1 gặp vấn đề này
  • 14 lượt xem
  • Trả lời mới nhất được viết bởi arctic.fox

more options

Using Firefox 57/58, when scrolling long pages in portrait orientation (such as on a Surface Pro tablet), black/white horizontal bars will appear midway down the page (see screenshot). I have tested this on a completely fresh install of Firefox 58 (with default settings and no addons) and the bug still occurs.

The bars will appear at random locations, and once rendered will scroll with the page, blocking out a section of content. Refreshing the viewport (eg. by switching the tab to another and back) will clear the bar, but new bars may appears once the content is scrolled again.

This error does not occur in landscape mode or for short pages (whose length does not exceed the vertical screen resolution), so I suspect this bug is related to how Firefox pre-renders the content (outside of the current viewport) while scrolling.

Tất cả các câu trả lời (4)

more options

Here is a screenshot of the issue:

https://i.imgur.com/aj2tnwn.png

more options

How about the link so others can see what it does to compare to what your saying?

more options

Any long page will exhibit the bug, but that particular page is Wikipedia: https://en.wikipedia.org/wiki/Arctic_fox

more options

Just posting here a workaround for anyone else experiencing this issue, disable Hardware Acceleration under:

Settings > General > Performance uncheck "Use hardware acceleration when available".

[thread] This thread suggests that turning on ClearType should fix the issue: philipp said

hi, thanks for reporting this. we are currently looking into this issue in https://bugzilla.mozilla.org/show_bug.cgi?id=1435472 it appears to be an issue that only affects users who have turned off cleartype font rendering within their windows settings. so a workaround for the moment would either be to turn cleartype back on or disabling hardware acceleration in firefox and restart the browser once: Firefox's performance settings

but that didn't work for me. Cleartype is on, but issue persists until I disable hardware acceleration.

Được chỉnh sửa bởi arctic.fox vào