X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

When Inputting URLs, Firefox Keeps Adding Foreign URL to the Beginning

Được đăng

Okay, this has happened before in the past but now it's happening consistently to the point that there were websites I can't access at all.

When I type a URL into Firefox and try to go to that website, Firefox keeps adding an entirely different URL to the front of it so that I can't access the site. For instance. I keep trying to go to http://nanowrimo.org. I type that into the bar but when I hit enter Firefox changes it to http://www.dell.comhttp//nanowrimo.org/.

Obviously that site doesn't exist. Then, if by some miracle I DO get to the site I'm trying to get to, if I hit refresh or try to go to another page on the site the dell url appears at the start and I get the Server Not Found error. I am not using bookmarks. I'm typing these things in by hand. My bookmarks work without any trouble. I tried disabling the fixup that adds www to the front of URLs but that didn't have any effect.

What's going on and how do I stop it?

Okay, this has happened before in the past but now it's happening consistently to the point that there were websites I can't access at all. When I type a URL into Firefox and try to go to that website, Firefox keeps adding an entirely different URL to the front of it so that I can't access the site. For instance. I keep trying to go to http://nanowrimo.org. I type that into the bar but when I hit enter Firefox changes it to http://www.dell.comhttp//nanowrimo.org/. Obviously that site doesn't exist. Then, if by some miracle I DO get to the site I'm trying to get to, if I hit refresh or try to go to another page on the site the dell url appears at the start and I get the Server Not Found error. I am not using bookmarks. I'm typing these things in by hand. My bookmarks work without any trouble. I tried disabling the fixup that adds www to the front of URLs but that didn't have any effect. What's going on and how do I stop it?

Được chỉnh sửa bởi milletclark vào

Giải pháp được chọn

Hmm, it really sounds like a fixup problem, but the prefix preference has its normal value of www?

Sometimes inexplicable problems are caused by corrupted program files. For that we suggestion:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 42.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder as follows:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Does a cleanly reinstalled Firefox handle typed URLs normally??

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
Đọc câu trả lời này trong ngữ cảnh 2

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • 5.1.40728.0
  • iTunes Detector Plug-in

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

Thông tin chi tiết

FredMcD
  • Top 10 Contributor
4224 giải pháp 58953 câu trả lời
Được đăng

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? ------------- You may have ad / mal-ware. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Người tạo câu hỏi

Tried starting it in safe mode. It still happens. I'll try the malware checker next.

Tried starting it in safe mode. It still happens. I'll try the malware checker next.

Người tạo câu hỏi

There seems to be something wrong with the Turnkey website all but one of the links in the malware article links to. I was able to get AdwCleaner but that's the only one since it was the only one not on the apparently defunct website the others were on.

There seems to be something wrong with the Turnkey website all but one of the links in the malware article links to. I was able to get AdwCleaner but that's the only one since it was the only one not on the apparently defunct website the others were on.
jscher2000
  • Top 10 Contributor
8635 giải pháp 70627 câu trả lời
Được đăng

Hmm, most of the links are on completely different servers. For example:

If all of those are getting diverted to some other site, you may have a more serious infection. You could try the specialized forums listed in the article in that case.

Hmm, most of the links are on completely different servers. For example: * www.malwarebytes.org * www.superantispyware.com * www.microsoft.com * support.kaspersky.com If all of those are getting diverted to some other site, you may have a more serious infection. You could try the specialized forums listed in the article in that case.

Người tạo câu hỏi

Okay, I downloaded every anti-malware program you listed and a great deal more of then just those. I ran them all. It hasn't made any difference.

Okay, I downloaded every anti-malware program you listed and a great deal more of then just those. I ran them all. It hasn't made any difference.
FredMcD
  • Top 10 Contributor
4224 giải pháp 58953 câu trả lời
Được đăng

Câu trả lời hữu ích

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Người tạo câu hỏi

FredMcD said

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

I tried that. And yes, the problem is still there in safe mode

''FredMcD [[#answer-812802|said]]'' <blockquote> Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? </blockquote> I tried that. And yes, the problem is still there in safe mode
FredMcD
  • Top 10 Contributor
4224 giải pháp 58953 câu trả lời
Được đăng

Call your ISP and start asking questions.

Call your ISP and start asking questions.

Người tạo câu hỏi

What has this got to do with my ISP? It doesn't happen in IE, only Firefox which suggests that this is a firefox issue. Also it doesn't happen on any of the other computers in the house. Only my laptop.

What has this got to do with my ISP? It doesn't happen in IE, only Firefox which suggests that this is a firefox issue. Also it doesn't happen on any of the other computers in the house. Only my laptop.
FredMcD
  • Top 10 Contributor
4224 giải pháp 58953 câu trả lời
Được đăng

It happens with Firefox in Safe Mode. It happens with the computer in Safe Mode. So I am thinking the problem is outside the computer.

It happens with Firefox in Safe Mode. It happens with the computer in Safe Mode. So I am thinking the problem is outside the computer.

Người tạo câu hỏi

Crap. I just hit the wrong button and now this question is marked as solved. How do I show that it is still unsolved?

Crap. I just hit the wrong button and now this question is marked as solved. How do I show that it is still unsolved?
FredMcD
  • Top 10 Contributor
4224 giải pháp 58953 câu trả lời
Được đăng

Go to that response. To its right there is a "not solve" link.

Go to that response. To its right there is a "not solve" link.
jscher2000
  • Top 10 Contributor
8635 giải pháp 70627 câu trả lời
Được đăng

Giải pháp được chọn

Hmm, it really sounds like a fixup problem, but the prefix preference has its normal value of www?

Sometimes inexplicable problems are caused by corrupted program files. For that we suggestion:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 42.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder as follows:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Does a cleanly reinstalled Firefox handle typed URLs normally??

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
Hmm, it really sounds like a fixup problem, but the prefix preference has its normal value of www? Sometimes inexplicable problems are caused by corrupted program files. For that we suggestion: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (1) Download a fresh installer for Firefox 42.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox (if applicable). (3) Rename the program folder as follows: ''(64-bit Windows folder names)'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox ''(32-bit Windows folder names)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Does a cleanly reinstalled Firefox handle typed URLs normally?? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins

Người tạo câu hỏi

jscher2000 said

Does a cleanly reinstalled Firefox handle typed URLs normally??


That seems to have solved the problem! Thanks so much.

''jscher2000 [[#answer-813633|said]]'' <blockquote> Does a cleanly reinstalled Firefox handle typed URLs normally?? </blockquote> That seems to have solved the problem! Thanks so much.