Kërkoni te Asistenca

Shmangni karremëzime gjoja asistence. S’do t’ju kërkojmë kurrë të bëni një thirrje apo të dërgoni tekst te një numër telefoni, apo të na jepni të dhëna personale. Ju lutemi, raportoni veprimtari të dyshimtë duke përdorur mundësinë “Raportoni Abuzim”.

Learn More

Firefox (Flatpak) displaying text in PDF files incorrectly

  • 3 përgjigje
  • 0 e kanë hasur këtë problem
  • 61 parje
  • Përgjigjja më e re nga zeroknight

more options

When i go to open a PDF file with Firefox, the text renders incorrectly (see image) for most PDF files, but not all (i'm not sure why. And this only happens with the Flatpak version of Firefox [1]. It doesn't happen with Firefox ESR (DEB version from my distribution) [2] and it doesn't happen if i view the same PDF file with pdf.js in a non-Firefox Flatpak app (GNOME Web) [3].

I've tried reinstalling and tried starting in troubleshoot mode, but neither seemed to fix the issue.

[1]:

  • Name: Firefox
  • Version: 117.0
  • Distribution ID: mozilla-flatpak

[2]:

  • Name: Firefox
  • Version: 102.15.0esr
  • Distribution ID: BLANK (preinstalled with Debian Linux 12)

[3]:

  • Name: GNOME Web (Flatpak)
  • Version: 44.6
When i go to open a PDF file with Firefox, the text renders incorrectly (see image) for most PDF files, but not all (i'm not sure why. And this only happens with the Flatpak version of Firefox [1]. It doesn't happen with Firefox ESR (DEB version from my distribution) [2] and it doesn't happen if i view the same PDF file with pdf.js in a non-Firefox Flatpak app (GNOME Web) [3]. I've tried reinstalling and tried starting in troubleshoot mode, but neither seemed to fix the issue. [1]: * '''Name''': Firefox * '''Version''': 117.0 * '''Distribution ID''': mozilla-flatpak [2]: * '''Name''': Firefox * '''Version''': 102.15.0esr * '''Distribution ID''': ''BLANK (preinstalled with Debian Linux 12)'' [3]: * '''Name''': GNOME Web (Flatpak) * '''Version''': 44.6
Foto të bashkëngjitura ekrani

Zgjidhje e zgjedhur

Go to about:config in the address bar and try changing pdfjs.disableFontFace to true.

Lexojeni këtë përgjigje brenda kontekstit 👍 2

Krejt Përgjigjet (3)

more options

It works for me on Ubuntu 23.04. Are all your flatpak packages up to date?

flatpak update

Does it still happen in a new profile? Alternatively you could refresh your existing profile.

The font being used is DejaVu for me.

E dobishme?

more options
Are all your flatpak packages up to date?

It appears to be so. Using the flatpak list command, i can see that it's on version 117.0 (stable branch).

Does it still happen in a new profile?

I hadn't tried that, but i've checked and it does happen in a new profile.

The font being used is DejaVu for me.

I have the default DejaVu font as the default font, but i have the "Allow pages to choose their own fonts, instead of your selections above" box checked, so it should be trying to display the following fonts, which are either embedded or standard (according to GNOME Document Viewer):

  • Times-Roman
  • Helvetica
  • Helvetica-Bold
  • Symbol
  • Times-Italic
  • Courier
  • Courier-Oblique
  • Times-BoldItalic

If i uncheck the "Allow pages to choose their own fonts, instead of your selections above" box, then text will display correctly (though not in the correct font of course). The only problem with this fix is that it also does this to normal web pages and makes everything look weird.

Since it's working for you on Ubuntu, i would think that it would be some dependency issue, but i don't believe that applies to Flatpaks since their dependencies are sandboxxed with the app.

Thank you for the reply! I really appreciate it.

Ndryshuar nga Logan B

E dobishme?

more options

Zgjidhja e Zgjedhur

Go to about:config in the address bar and try changing pdfjs.disableFontFace to true.

E dobishme?

Bëni një pyetje

Duhet të bëni hyrjen te llogaria juaj që t’i përgjigjeni postimeve. Ju lutemi, filloni me një pyetje të re, nëse nuk keni ende një llogari.