Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

can't open downloaded pdf files from firefox

  • 9 Antworten
  • 131 haben dieses Problem
  • 13 Aufrufe
  • Letzte Antwort von 22droll

more options


when i download a pdf file and open it from downloaded file list it opens with gimp. now i've tried all i can. the gnome-open association is with evince. i've tried changing the application management in firefox preferences to gnome-open and evince for pdf. still pdf files can only be opened with gimp. what should be done now.

MozPlugger 1.10 is already installed. but i dont have the adminstrative powers

i'm pasting the mozpluggerrc (pdf part) application/pdf: pdf: PDF file application/x-pdf: pdf: PDF file text/pdf: pdf: PDF file text/x-pdf: pdf: PDF file repeat swallow(acroread) fill: acroread7 -openInNewWindow "$file" repeat swallow(documentShell) fill: acroread5 -geometry +9000+9000 +useFrontEndProgram "$file" repeat noisy swallow(evince) fill: evince "$file" repeat noisy swallow(kpdf) fill: kpdf "$file" repeat noisy swallow(Xpdf) fill: xpdf -g +9000+9000 "$file" GV()

Alle Antworten (9)

more options

Hi there,

Right click on that PDF file in Firefox and click properties. Then click 'Change', to the right of 'Open with:'. Finally select the application you'd like to open PDF files with and you should be good to go.

Regards, Ziggy

more options

"Right click on that PDF file in Firefox and click properties." couldn't be done. btw, i'm working in linux.

more options

You are using an old and no longer supported Firefox 3.0.15 version.
You should update to 3.5.x or 3.6.x once updates are enabled (may not work now because of a crash investigation)

Delete mimeTypes.rdf in the Profile Folder

See http://kb.mozillazine.org/File_types_and_download_actions#Resetting_download_actions

more options

deleting mimetyes.rdf didn't help. i can't update to higher versions as i don't have adminstrative powers. all i can do is to download and build new one. and i'm not sure if it's gonna help.

more options

Try to uninstall Firefox and reinstall it: Install Firefox on Linux .

more options

"i don't have adminstrative powers."

so i think i better compile a new version. though still waiting to see if any solution is available.

more options

What stops you from compiling the latest version? You should always make sure that you've got the latest stable release.

more options

IE works. Google Chrome works. Tried every suggestion offered to get firefox to work and nothing worked for me. Tried Adobe. Tried Foxit. Nothing works. Never used Google Chrome but gave it a try and yes it opened every PDF file I could through at it. I get my Bank statements from two different banks and Firefox 4.1 can't handle it. This has been going on for over a month for me with no easy fix. I see a lot of people with the same problem. Can someone from Firefox give Chrome or IE a call and see if they might have an answer on how to fix the Firefox problem.

more options

On a Mac, go to "tools," click on "add-ons," which will take you to the Add-on Manager. Click on "plug-ins" and disable "Adobe Acrobat NPAPI Plug-in, Version 10.1.3" This recent update for Acrobat isn't compatible with Firefox 11.0. I hope they get the bugs out soon, but disabling the Acrobat plug-in is the only thing that let's me download pdfs on Firefox at the present. I had no problems with Safari, though. Weird!