As preferências não são guardadas - Como corrigir?

Por vezes as alterações que faz às preferências podem não ser guardadas. Por exemplo, pode alterar uma preferência na janela Opções Preferências e verificar ao voltar a abrir a mesma janela, que essa preferência apresenta o valor anterior à modificação efetuada.

As possíveis causas e soluções deste problema serão diferentes consoante não consiga guardar as alterações feitas a apenas algumas preferências específicas ou não consiga guardar quaisquer alterações efetuadas a todas e quaisquer preferências. Este artigo pode ainda aplicar-se se, após a atualização do Firefox, for apresentado um separador denominado O Firefox foi atualizado, com a indicação de que o programa foi atualizado para a versão mais recente, de todas as vezes que executar o Firefox.

Renove o Firefox para resolver o problema

A forma mais fácil de solucionar este problema é restaurar o Firefox para o seu estado original, ao mesmo tempo que mantém a informação essencial. Para além de repor todas as preferências para os seus valores predefinidos, renovar o Firefox irá também corrigir uma data de outros problemas, incluindo problemas causados por extensões ou com dados e definições que são armazenadas noutros ficheiros no seu perfil do Firefox. Se gostaria de experimentar uma correção mais precisa, avance esta secção e experimente as soluções abaixo.

Nota: Ao utilizar a funcionalidade de renovação, os seus marcadores, histórico de navegação, separadores abertos, janelas, palavras-passe, cookies e informações de auto-preenchimento de formulários Web serão guardadas. No entanto, as suas extensões e temas serão removidos e as suas preferências restauradas.Ao utilizar a funcionalidade de renovação, os seus marcadores, histórico de navegação, separadores abertos, janelas, palavras-passe, cookies e informações de auto-preenchimento de formulários Web serão guardadas. No entanto, as suas extensões e temas serão removidos e as suas preferências restauradas.Ao utilizar a funcionalidade de renovação, os seus marcadores, histórico de navegação, separadores abertos, janelas, palavras-passe, cookies e informações de auto-preenchimento de formulários Web serão guardadas. No entanto, as suas extensões e temas serão removidos; os separadores abertos, janelas e grupos de separadores não serão guardados; e as suas preferências serão restauradas. Saber mais.

  1. Clique no botão de menu New Fx Menu e depois clique em ajuda Help-29 .
  2. Do menu de Ajuda escolha Informação para resolução de problemas.
    Se não for possível aceder ao menu Ajuda, escreva about:support na sua barra de endereço para carregar a página Informação para resolução de problemas.
  3. Clique no botão Renovar o Firefox no canto superior direito da página Informação para resolução de problemas.
    Refresh 35 Win Refresh 35 Mac Refresh 35 Lin
  4. Para continuar, clique em Renovar o Firefox na janela de confirmação que é apresentada.
  5. O Firefox irá fechar para se auto-renovar. Quanto esta operação estiver concluída, uma janela irá listar a informação que foi importada. Clique em Concluir e o Firefox será aberto.
Nota: Existe também um botão Renovar o Firefox na janela do modo de segurança do Firefox, se não conseguir iniciar o Firefox normalmente. Se não consegue encontrar o botão Atualizar na sua versão do Firefox, pode também atualizar manualmente criando um novo perfil. Consulte estas instruções sobre como criar um novo perfil.

Preferências específicas não são guardadas

Se uma preferência específica no Firefox assume repetidamente os seus valores pré-definidos, ou se não consegue guardar a alteração introduzida a algumas preferências específicas, mas não tiver problemas em guardar as modificações que fizer às demais preferências, poderá ter um dos seguintes problemas.

Programas de terceiros alteram as definições do Firefox

Alguns programas obrigam o Firefox a modificar determinadas definições. Abaixo estão listados alguns dos programas conhecidos por provocarem este problema e respetivas sugestões para evitar que o Firefox seja forçado a modificar as suas definições:

  • Creative ZenCast modifica o agente de utilizador do Firefox, interferindo com o Java.
    • Desinstale o programa
  • McAfee Privacy Service desativa o bloqueador de pop-ups.
  • Norton 360 inclui uma ferramenta denominada "Firefox Privacy Cleanup" que, ao ser utilizada, modifica as suas opções de privacidade, impedindo-o de manter o seu histórico de navegação, cookies ou outros dados privados entre sessões.

Algumas barras de ferramentas de terceiros e extras alteram a página inicial do Firefox e as definições de pesquisa. Pode facilmente repor estas definições com o extra SearchReset.

O ficheiro user.js substitui as preferências

Se não tiver instalado nenhum dos programas mencionados acima, ou seSe seguiu as sugestões, e algumas preferências específicas continuam a não serem guardadas, poderá ter que editar os ficheiros de configuração do Firefox você mesmo. Não se preocupe, é muito fácil. Aqui está como o fazer.

  1. Abrir a sua pasta de perfil:

    No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.Clique no botão de menu New Fx Menu , clique em ajuda Help-29 e selecione Informação sobre a Resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.

  2. Por baixo da secção Noções básicas da aplicação , clique em Mostrar pastaAbrir pastaMostrar no FinderAbrir pasta. A janela com o seu perfil ficheirospasta será apresentada.
  3. Nota: Se não consegue abrir ou utilizar o Firefox, siga a instruções em encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair.

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  5. Abra o ficheiro user.js num editor de texto (como o Notepad, Gedit, Leafpad ou KateTextEdit)).
    • Se não existir nenhum ficheiro user.js, estas instruções não poderão ajudá-lo.
  1. Elimine as linhas relativas às opções/preferências que pretende modificar. Pode eliminar todas as linhas se desejar modificar tudo.
  2. Guarde o ficheiro e feche o editor de texto.

Agora já deverá ser capaz de modificar as suas preferências no Firefox.

O ficheiro de programa do Firefox bloqueia ou impede alterações a determinadas preferências

A sua instalação do Firefox pode ter sido personalizada para adicionar um ficheiro de configuração do programa que bloqueia determinadas definições ou impede determinadas alterações de serem guardadas. Siga o passo Reinstalar o Firefox no artigo Identificar e diagnosticar problemas do Firefox para remover o programa do Firefox do seu computador e de seguida reinstalar uma nova cópia do Firefox. (Reinstalar o Firefox desta forma não irá remover os seus dados de utilizador e definições, visto que estas informações são guardadas numa localização diferente dos ficheiros do programa.)

Impossível guardar quaisquer preferências ou definições

Se nenhuma das suas definições são guardadas, se lhe é mostrado o separador Firefox está atualizado sempre que inicia o Firefox, ou se experimentou os passos acima sem resultados, o ficheiro que o Firefox utiliza para guardar as suas preferências pode estar bloqueado ou corrompido.

Ficheiro de preferências bloqueado

O Firefox poderá não conseguir guardar as suas definições se o ficheiro prefs.js (ou o ficheiro prefs.js.moztmp, caso exista) estiver protegido contra escrita ou se existirem cópias de segurança de outros ficheiros de preferências.

  1. Abrir a sua pasta de perfil:

    No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.Clique no botão de menu New Fx Menu , clique em ajuda Help-29 e selecione Informação sobre a Resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.

  2. Por baixo da secção Noções básicas da aplicação , clique em Mostrar pastaAbrir pastaMostrar no FinderAbrir pasta. A janela com o seu perfil ficheirospasta será apresentada.
  3. Nota: Se não consegue abrir ou utilizar o Firefox, siga a instruções em encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair.

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  5. Localize o ficheiro prefs.js (e, caso exista, o ficheiro prefs.js.moztmp).
  6. Clique com o botão direito do rato sobre cada um dos ficheiros e selecione Propriedades no menu de contexto. Verifique se na linha Atributos a caixa Só de leitura não se encontra selecionada.
    • Se o RealPlayer estiver aberto, isso poderá estar a bloquear o ficheiro prefs.js. Fechar o RealPlayer deverá desbloqueá-lo.
  7. Elimine todos os ficheiros prefs-n.js em que n seja um número (por exemplo prefs-2.js).
  8. Elimine o ficheiro Invalidprefs.js, caso exista.
  9. Reinicie o Firefox. Agora já deverá poder guardar as suas preferências.
  1. Abrir a sua pasta de perfil:

    No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.Clique no botão de menu New Fx Menu , clique em ajuda Help-29 e selecione Informação sobre a Resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.

  2. Por baixo da secção Noções básicas da aplicação , clique em Mostrar pastaAbrir pastaMostrar no FinderAbrir pasta. A janela com o seu perfil ficheirospasta será apresentada.
  3. Nota: Se não consegue abrir ou utilizar o Firefox, siga a instruções em encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair.

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  5. Localize o ficheiro prefs.js (e, caso exista, o ficheiro prefs.js.moztmp).
  6. Certifique-se de que possui permissões de escrita para cada um dos ficheiros.
  7. Elimine todos os ficheiros prefs-n.js em que n seja um número (por exemplo prefs-2.js).
  8. Elimine o ficheiro Invalidprefs.js, caso exista.
  9. Reinicie o Firefox. Agora já deverá poder guardar as suas preferências.
  1. Abrir a sua pasta de perfil:

    No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.Clique no botão de menu New Fx Menu , clique em ajuda Help-29 e selecione Informação sobre a Resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.

  2. Por baixo da secção Noções básicas da aplicação , clique em Mostrar pastaAbrir pastaMostrar no FinderAbrir pasta. A janela com o seu perfil ficheirospasta será apresentada.
  3. Nota: Se não consegue abrir ou utilizar o Firefox, siga a instruções em encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair.

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  5. Localize o ficheiro prefs.js (e, caso exista, o ficheiro prefs.js.moztmp).
  6. Para cada ficheiro, pressione a tecla Ctrl enquanto clica no ficheiro, e selecione Obter informações.
  7. Certifique-se que a opção Bloqueado não está selecionada.
  8. Elimine todos os ficheiros prefs-n.js em que n seja um número (por exemplo prefs-2.js).
  9. Elimine o ficheiro Invalidprefs.js, caso exista.
  10. Reinicie o Firefox. Agora já deverá poder guardar as suas preferências.

Ficheiro de preferências corrompido

O ficheiro de preferências poderá estar corrompido, impedindo o Firefox de o utilizar. Se eliminar este ficheiro, o Firefox irá criar um outro automaticamente quando for necessário. Aqui está como eliminar o ficheiro prefs.js.

Isto irá remover todas as suas definições personalizadas, assim como definições para muitas extensões.
  1. Abrir a sua pasta de perfil:

    No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Informação sobre a resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.Clique no botão de menu New Fx Menu , clique em ajuda Help-29 e selecione Informação sobre a Resolução de problemas. O separador com informações sobre a resolução de problemas será apresentado.

  2. Por baixo da secção Noções básicas da aplicação , clique em Mostrar pastaAbrir pastaMostrar no FinderAbrir pasta. A janela com o seu perfil ficheirospasta será apresentada.
  3. Nota: Se não consegue abrir ou utilizar o Firefox, siga a instruções em encontrar o seu perfil sem abrir o Firefox.

  4. No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair.

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  5. Localize o ficheiro prefs.js (e, caso exista, o ficheiro prefs.js.moztmp).
  6. Elimine esses ficheiros e os ficheiros prefs-n.js em que n seja um número (por ex. prefs-2.js).
  7. Elimine o ficheiro Invalidprefs.js, caso exista.


Outras soluções

  • O seu problema pode ter origem em malware. Consulte Solucionar problemas no Firefox causados por software malicioso para detalhes.
  • Algum software, como o Advanced SystemCare com Surfing Protection, pode proteger ficheiros no perfil do Firefox contra alterações. Se tiver um software deste tipo, confirme as definições ou remova este software.




Baseado na informação de Preferências não são guardadas (mozillaZine KB)

Este artigo foi útil? Por favor, aguarde...

Essas pessoas maravilhosas ajudaram a escrever este artigo: cesperanc, nop60130, Y4zata, albertdecastro. Você também pode ajudar - descubra como.