Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Trying to stream Live TV from http://www.cnbc.com/live-tv/ and it complains "You are in Private Browsing Mode" when FF is not in PBM."

  • 25 replies
  • 1 has this problem
  • 191 views
  • Last reply by Happy112

more options

FF Version 59.0.1 (64-bit) Windoze 7 64-bit ABP Disabled for cnbc.com NOT in Private Browser Mode Cookies Enabled for cnbc.com Tools->Options->Privacy&Security->ShowCookies shows that a CNBC cookie is present.

Cable provider: Spectrum/Brighthouse

Window from cbnc.com/live-tv/ follows:

You are in Private Browsing Mode

We noticed you are attempting to use our site in a private or incognito browsing mode which interferes with cookies. To utilize this site you must be in a normal browser mode with cookies enabled.

I gotta cut the Cable TV cord.This is my first attempt.

All Replies (20)

more options

Hello,

Cookies enabled, content-filtering add-ons disabled, not in Private Browsing mode ....... (good thinking  !)

Could it be that you're using Tracking Protection  ?

(You don't have to be in Private Browsing mode)

See : https://support.mozilla.org/en-US/kb/tracking-protection

And : https://blog.mozilla.org/firefox/tracking-protection-always-on/

Some sites will mistake Tracking Protection for Private Browsing ....

more options

Hey Happy,

Thanks for the info and the quick reply. Here we go...

Options->Privacy&Security->TrackingProtection->OnlyInPrivateWindows Changed to Never No Change.

Deleted CNBC Cookie to see if it comes back when I refresh /cnbc.com/live-tv just in case cookie contents not correct.

CNBC Cookie reappeared after refresh. Assumption was that the Cookie contents may have been corrupt but are now "new & improved" with the refresh.

In the URL Title bar, the Shield is NOT present. The Circled 'i' is present and so is the Manage-Plug-In-Use icon.

Clicked on Manage-Plug-In-Use icon and FF asked me "Do you want to allow Adobe Flash to run on this site?"

I selected the blue "Allow" tab but I did not check the "Remember this decision" check box.

Hit FF Refresh

No change from CNBC.com. However, now the Shield icon is displayed (it wasn't before) with a "How Tracking Protection works (1 of 3)" drop down displayed.

I clicked on the Shield Icon and got (see screen capture). I'm just getting started on this and there is a ton of stuff to try. Documenting every combination attempt will be daunting. Time to read and try a bunch of things. I'll be back if I figure something out. Until then... good hunting.

Heffie

Modified by Heffie

more options

Hi Heffie  !

Could you try to upload that screenshot again, please  ? (not working.... )

You take all the time you need reading and trying 'stuff', you hear  !

more options

Here ya go...

more options

Thank you  !

And : Yay  ! The screenshot shows that you are indeed using Tracking Protection .....

more options

Should you want to disable Tracking Protection on all sites :

Type in the address bar about:config (press Enter) (promise to be careful, if asked)

Type in the search bar tracking

and look for the preference privacy.trackingprotection.enabled

and set its value to false

Then close and restart Firefox.

more options

Tried your suggestion. Same problem.

Interesting observation. I set privacy.trackingprotection.enabled to true and then looked at the Tracking Protection use the Options screen and the radio button Always was selected. The "circled i" showed "Tracking Protection: No tracking elements detected on this page" for the cnbc.com/live-tv/ tab.

Hmmm.

I then set privacy.trackingprotection.enabled to false and then looked at the Tracking Protection use the options screen and the radio button "Only in private windows" was selected.

Looks like FF is using a binary value to control privacy.trackingprotection.enabled which is controlled via Options with three radio buttons (Always, Only in private windows, Never).

Does not compute.

So I selected "Never" via Options and refreshed about:config and privacy.trackingprotection.enabled remained false.

This is too convoluted. I need to create a state table and collect screen shots for each iteration. No, I'm not going to try to explain what I just said. Hopefully it will make sense when I actually do it.

I have a killer headache and this is officially a tomorrow problem. I need to do more reading. Better a fresh start.

Until then...

more options

There are two preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste track and pause while the list is filtered

(3) Look at these two together:

Preference CombinationEffect
privacy.trackingprotection.enabled => false
privacy.trackingprotection.pbmode.enabled => true
Tracking Protection ONLY in private windows (default)
 
privacy.trackingprotection.enabled => true
privacy.trackingprotection.pbmode.enabled => true or false
Tracking Protection in ALL windows
 
privacy.trackingprotection.enabled => false
privacy.trackingprotection.pbmode.enabled => false
No Tracking Protection in any windows
 

Modified by jscher2000

more options

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can also try to enable third-party cookies to see if that has effect.

more options

Heffie said

I have a killer headache and this is officially a tomorrow problem. I need to do more reading. Better a fresh start.

Totally understand  ! One shouldn't have to jump through hoops just to use the computer for work, email, YouTube etc.. We can't expect every user to be an IT professional or computer scientist ....

more options

Well, this was off the wall. But I'm there.

It has to do with the site not being a secure connection. There were two ways to get it.

One was to override FF's not allowing an unsecured connection. The other was to go to https://watch.spectrum.net/livetv and simple selecting the channel.

Now the problem is that I don't remember exactly what I did to get there. The first step is to wake up and smell the coffee. That requires I go make the coffee!

Ugh...

more options

So you're an IT guy?

Now that I've made my first baby step and can watch TV (well, CNBC) on my Desktop, how do I set up a server to watch TV on my TVs? I have a somewhat old Sony Bravia. I can watch Netflix, Amazon Prime, etc, using my Brighthouse/Spectrum modem. I can see my PC being an available in the list of Internet sources. But I have never been able to connect to it.

How do I setup a Server on my PC so I can select it the same way I select Netflix, etc.?

more options

Meanwhile I've exchanged emails with CNBC.com, and just now I explained about how they might mistake Tracking Protection for Private Browsing - they promised to get back to me ......

more options

Heffie said

It has to do with the site not being a secure connection.

We're still talking about CNBC.com, aren't we  ?

That site does not have an insecure connection  !

more options

Heffie said

So you're an IT guy?

Definately, absolutely not  ! Far from it  !

Apart from the fact that I'm not a guy : I'm a user, just like you.

Most contributors on this support forum are volunteers, users, trying to help other users in their spare time. But just between you and I : some of them are real computer nerds and geeks - and they are the ones who can help you way better than I ever could ......

more options

Oops. I was using "guy" as a generic term for any individual. Sorry, I'm an old fart, it's a generational thing.

Yes, we are still talking about FF and streaming live CNBC to my desktop using FF. Please review the screen capture I uploaded yesterday. The first item in the CNBC tab "drop down" is:

"www.cnbc.com Connection is Not Secure"

After I followed the '>' on the above, the background image changes to be actual live CNBC but with the same drop down from yesterday. This is different from yesterday.

Now this is the stupid scary part, all I did was hit the ESC key and the drop down went away and voila, I was watching CNBC live using FF.

I know, this doesn't make sense to me either. But that's how I got there. The other way was to just go to https://watch.spectrum.net/livetv and log in to Spectrum as usual.

So we have a solution to stream CNBC live, and all other channels from my cable provider, using FF on my DESKTOP. I can almost cut the cord and just use the modem from my cable company. That will take a big chunk out of my my cable bill.

Now I'm not talking about CNBC. Is this where Roku, etc. come in to stream live TV using just my modem and a HDMI input on my TV? I understand if you choose to not address this question as it is no longer a FF issue.

It was fun. I got to use my brain again - kind of...

Modified by Heffie

more options

jscher2000 & cor-el & Happy,

Thank you all very much for your feedback. It is very much appreciated and collectively helped push back the frontiers of my ignorance.

Heffie

more options

Heffie said

So we have a solution to stream CNBC live, and all other channels from my cable provider, using FF on my DESKTOP. I can almost cut the cord and just use the modem from my cable company. That will take a big chunk out of my my cable bill.

Well, I'm glad you sorted that out - I can stop exchanging emails with CNBC.com then ......

Now I'm not talking about CNBC. Is this where Roku, etc. come in to stream live TV using just my modem and a HDMI input on my TV? I understand if you choose to not address this question as it is no longer a FF issue.

I did not choose not to address that question - I was still busy trying to find a proper solution to your original problem.

But I found this (only applies to Andoid, though) :

https://support.mozilla.org/en-US/kb/use-firefox-android-send-videos-your-roku

And I found this add-on, but I don't know if it will do what you want (worth a try, though) :

https://addons.mozilla.org/en-US/firefox/addon/keentv/?src=search

more options

Happy,

I'd continue talking with CNBC. FF did report cnbc.com/live-tv as Connection is Not Secure.

Thanks again,

Old Fart Heffie

more options

Heffie said

I'd continue talking with CNBC. FF did report cnbc.com/live-tv as Connection is Not Secure.

I contradicted you earlier, because it doesn't say 'Connection is Not Secure' on the other pages - only on 'Live TV'.

Would you please take a look at this article :

https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean

Old Fart Heffie

Go easy on the curry ....

  1. 1
  2. 2