Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is now opening new tabs for the same URL. How do I make it stop?

  • 7 replies
  • 1 has this problem
  • 4 views
  • Last reply by cor-el

more options

bold text Firefox is now opening new tabs for the same URL. How do I make it stop? I thought it started when I added honey. So I deleted that add on. No effect. Is this some new normal? Is there an add on or something to make this stop?

All Replies (7)

more options

If you are getting random tabs opened on your Firefox browser, it sounds like an installed add-on may be to blame. This can easily be tested by testing Firefox in Safe Mode. If the issue goes away while in safe mode, you need to figure out what add-on is causing tabs to open.

Hope this helps.

Helpful?

more options

When do the new tabs open (if you click a link or open a bookmark or different) ?

Helpful?

more options

If I browse through amazon I get a new tab for every search, every time I add something to my cart it opens a new tab, every item I look at- new tab. I deleted Honey but it hasn't stopped. Other things like a pop up window for a tracker stopping add on opens up. I can't find a setting in any of the apps that would cause that. Any site that I look at multiple items, I get multiple tabs.

Helpful?

more options

Does the issue still happen when you are running Firefox in Safe Mode?

Also, just to confirm, you are having this issue on a Mac computer, correct?

Helpful?

more options

Yes I'm on a mac running 10.11.6. How do I run firefox in safe mode?

Helpful?

more options

There's a number of different ways to open Firefox in Safe Mode. The easiest is to press the menu button in the top right of Firefox, select Help and Restart with add-ons disabled...

More information can be found on the Troubleshoot Firefox issues using Safe Mode page.

Helpful?

more options

On Mac you can hold down the Options key while starting Firefox to start Firefox in Safe Mode.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.