Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

my Firefox has been hijacked by Bing

  • 25 replies
  • 19 have this problem
  • 1162 views
  • Last reply by Mark1620

more options

Firefox is default browser, suddenly Bing is replacing it and can't get firefox shortcut to work. It automatically goes to Bing

Chosen solution

Answer to your question: The BingPopup.exe and log listed above was discovered by my search of the date and time of changes to my Windows Directory. I am running Avast Professional. I did a scan, it found nothing.

I checked my 5 extensions, turned them all off, but that had no affect. So, I removed the last 3, which I could not remember installing on Firefox since the original install; and rebooted, but that had no affect.

It appears to me the BingPopup.exe file log indicates a number of changes to ni.dll files found in various sub-directories.

Seems I need to run an exe file to counter the BingPopup.exe. or reset the OS to previous date, neither of which I have any experience with.

Read this answer in context 👍 0

All Replies (20)

more options

hello dunnepatti,

Do you have the toolbar with the URL? If that bar is missing, try one of these to restore it:

  • right-click a blank area of the tab bar > Navigation Toolbar
  • tap the Alt key to activate the classic menu bar > View > Toolbars > Navigation Toolbar

If you don't have any menus or toolbars, try the F11 key, which switches between full screen and normal views.

Can you get the button?

If you have the Navigation Toolbar but the button is missing, you can restore the default layout using the Customize feature. Either:

  • right-click a blank area of the tab bar > Customize
  • tap the Alt key to activate the classic menu bar > View > Toolbars > Customize

In the dialog, click the Restore Default Set button.

Any luck?

By the way, by default, these keyboard shortcuts also will navigate "back":

  • Backspace key, when you're not in an editing control (this can be disabled if it causes problems, see browser.backspace_action)
  • Alt+Left Arrow (Alt+Right Arrow goes Forward)


I hope resolve the problem please reply me back.


thank you!

Helpful?

more options

Thank you so much. I will let you know the outcome.

Helpful?

more options

Ok, thanks for all the information. It did not work. I have my navigation toolbar and the icon for Firefox. When I click on icon, it brings up Bing, so aggravating.

Helpful?

more options

Still haven't found a solution One thing that has happened is under General, the box to make firefox my default browser, the ck mark is a faint blue. Other check marks are a deeper blue. Also underneath it says firefox is my default browser. Bing still comes up.

Helpful?

more options

Hi dunnepatti, the page that initially shows when you start Firefox -- if Firefox didn't restore your previous session -- would be your home page. Can you check that setting? More info in the following article:

How to set the home page

Helpful?

more options

I have used Firefox for probably 15 years and I have my homepage opens with the tabs that I regularly use. Over the years I have had different home pages but this works best for me. Now, when I click on Firefox, instead of getting my page with the icons I have set up in firefox, Bing opens it's page.

Helpful?

more options

It seems to me somehow my setting on making Firefox my default browser has been manipulated, even tho it still says it is my default. Like I said earlier the check mark is a faint blue. In addition, I can't click on it to remove it or change it. My ability to do that has been deactivated somehow.

Helpful?

more options

dunnepatti said

I have used Firefox for probably 15 years and I have my homepage opens with the tabs that I regularly use. Over the years I have had different home pages but this works best for me. Now, when I click on Firefox, instead of getting my page with the icons I have set up in firefox, Bing opens it's page.

Home button still opens those tabs? They still appear in a new window (Ctrl+n)?

In that case, if you are using a desktop shortcut or pinned taskbar icon, you should check to see whether it has been modified with the Bing address. Either:

  • Right-click a Firefox desktop shortcut, then click Properties
  • Right-click a Firefox icon pinned to the Taskbar then right-click Mozilla Firefox, then click Properties

Windows should show the Shortcut tab and select the Target field. The Target usually is along the following lines:

  • "C:\Program Files\Mozilla Firefox\firefox.exe"
  • "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

If there is anything extra after that which you did not put there, you can remove it.


dunnepatti said

It seems to me somehow my setting on making Firefox my default browser has been manipulated, even tho it still says it is my default. Like I said earlier the check mark is a faint blue. In addition, I can't click on it to remove it or change it. My ability to do that has been deactivated somehow.

Do you mean the checkbox on Firefox's Options page? That's normal.

Helpful?

more options

Yes, the Options page. I've never noticed it being a faint blue and it has never not let me uncheck it to change. It cannot be clicked.

Helpful?

more options

I am wondering if I need to reset the computer to several days ago before it started doing this. but, hoping there is something easier and wondering if it would still persist. Thinking there is a good chance it won't.

Helpful?

more options

dunnepatti said

Yes, the Options page. I've never noticed it being a faint blue and it has never not let me uncheck it to change. It cannot be clicked.

If you want to change it, you can go behind the scenes. But I don't think it is related to this problem.

So to summarize:

(A) When you use your Firefox shortcut on the desktop or Windows Taskbar, it launches and shows a Bing page instead of your regular tabs

(B) Bing has not taken over as your home page on the Firefox Options page

(C) Bing is not added to the shortcut you use to start Firefox

The other thing to check would be add-ons -- a possible culprit would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, private search, Bing, etc.? Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

Helpful?

more options

Yes, to all three A-C. I will re-check my extensions. I don't have that many, but I will look again. I did download a couple of programs a few days ago to help with my video and uninstalled them after they didn't help. I think there may have been something that was added to my computer. I don't even remember the names of them. Thanks for your help.

Helpful?

more options

I only had 2 extensions, Adblock Plus and Honey (removed Honey). No luck.

Helpful?

more options

If you check the address bar of the unwanted startup page, is the URL just https://www.bing.com/ or are there any extra parameters on it?

Helpful?

more options

Thank you so much for your help. The good news it's fixed! the bad news is I don't know how I did it. I have been playing around with it all day and somehow stumbled on something that fixed it.

Helpful?

more options

don't know if this will help anyone in the future, but the Bing URL was:

https://www.bing.com/?pc=COSP&ptag=D060220-N0600A21ABFDD9D88F4162B1F&form=CONMHP&conlogo=CT3332016

Helpful?

more options

Some software you installed recently may have been "monetized" with unwanted software (or less charitably, crap). If the unwanted URL comes back, it may be helpful to scan with the tools listed in this support article: Troubleshoot Firefox issues caused by malware. These on-demand scanners are free or have a free trial.

Helpful?

more options

thank you! I think that is what happened. I appreciate your time and will save this information.

Helpful?

more options

hello dunnepatti,

I've been scouring the internet for a few days now looking for a solution as to how to permanently remove Bing as my default browser, but none of them have worked. Every time I open Nightly, I go to options, and check to see the default search engine. It's always Bing. So I delete Bing, and change it to Google. Well, when I close the browser, I have a nice surprise waiting for me. Bing. I've spent almost all day scanning my computer with different anti-virus/malware programs, deleted several viruses (hopefully there aren't any more), and it still happens. I've started Nightly in safe mode with all of the add-ons off, and it still happens. Went to about:config, prefs.js, user.js, and searched for invalidprefs.js (and so on), and nothing worked. One thing I've noticed, is after having refreshed Nightly (I don't want to go through the whole changing my settings and customization thing again, so no screenshots), the list of browsers had Bing twice. One on top (the one that comes with the browser), and one on bottom (the one that keeps getting added). For this reason, I think it could be malware, or some unwanted program that I, for the life of me, cannot find in file explorer or control panel. Any help would be appreciated, as this issue is incredibly infuriating, thank you.

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer

Helpful?

more options

I have this problem of Bing hijacking. It suddenly started several FF updates ago. Until then my default browser was DuckDuckGo. After the change the Bing page became the opening tab. Opening a second or later tab used DuckDuckGo go figure. Paddling around the internet, consensus suggested solution was to reset FF. I have used the advanced config to inspect the whole config listing. The following three entries are of interest browser.search.defaultenginename browser.search.selectedEngine extensions.webextensions.uuids .....f","bing@search.mozilla.org":"407b2451-1db8-4954-ab1f-a7db606f47ef","eb... since they reference Bing default search. Can these be safely deleted or changed to another preference? Any advice would be helpful.

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.