Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

web pages don't render correctly

  • 8 replies
  • 1 has this problem
  • 380 views
  • Last reply by rstiltskin

more options

The problem for me is usually text on top of other text. I'm adding a screenshot of part of the google news page.

Attached screenshots

Chosen solution

This can happen if you block a special icon font file and Firefox is showing the ALT text instead.

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

Read this answer in context 👍 1

All Replies (8)

more options

Check your zoom controls.

<Control> (Mac=<Command>) + (plus) enlarge - (minus) reduce 0 (zero) restore


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Suggest work on your Video Card Drivers as most of it is errors that allow you to see stuff : featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled',

more options

FredMcD said

Check your zoom controls. <Control> (Mac=<Command>) + (plus) enlarge - (minus) reduce 0 (zero) restore

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Changing the zoom control had no effect on text on top of text. I've already tried the other suggestions about cookies/cache/safe mode/disable hardware acceleration.

Pkshadow, I have no idea what your post means. I'm using latest nvidia drivers with my nvidia card.

Other browsers like Safari and Chrome do not have the problem of text on top of text.

Modified by rstiltskin

more options

Pkshadow said

Suggest work on your Video Card Drivers as most of it is errors that allow you to see stuff : featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled',

It explains itself :

u'blocked' = BAD u'Acceleration blocked by platform = Bad or Card can not do Hardware Acceleration u'OpenGL u'unavailable = a wack of drivers https://en.wikipedia.org/wiki/OpenGL https://www.khronos.org/opengl/

  • Uninstall and Reinstall your Drivers

Just because other browsers can do something does not mean that that is ok. Most other browsers have less adherence to W3C.org rules for making web pages and for Browsers displaying them.

Try a Refresh after have fixed the drivers : Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st:

then

more options

Pkshadow said

Pkshadow said
"It explains itself" Not for me.(rstiltskin) Just because other browsers can do something does not mean that that is ok. Most other browsers have less adherence to W3C.org rules for making web pages and for Browsers displaying them. Try a Refresh after have fixed the drivers : Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: then

I'm using openSUSE Tumbleweed which is a rolling release. The kernel is updated 3-4 times a week which means I have to compile and reinstall the nvidia drivers after every kernel update. I use Firefox Sync if I need to reinstall my OS, which restores most of my settings and my bookmarks. I don't see the point of backing up my bookmarks or creating a new profile folder just because some web pages don't render correctly when I use Sync.

I messed up the quotes above but I hope you get the gist.

Modified by rstiltskin

more options
more options

Chosen Solution

This can happen if you block a special icon font file and Firefox is showing the ALT text instead.

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

more options

cor-el said

This can happen if you block a special icon font file and Firefox is showing the ALT text instead.

I checked "allow pages to choose their own fonts" and that fixed it. Thanks for the help.