Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The Awesome Bar is Not Working Since 11/16/16, FF 50.0

  • 6 replies
  • 1 has this problem
  • 28 views
  • Last reply by Happy112

more options

FF version 50.0 Win10 build 1607 (latest updates)

The Awesome Bar has stopped working (aka search bar, URL bar).

If I start typing in it, the drop-down box opens, I select an item, but FF doesn't do anything. If I hit <Enter>, nothing happens.

It is the same if I "hand type" in the complete URL, or paste a URL into the Awesome bar.

There is no issue browsing from Favorites, Bookmarks, or clicking URLs in a web page, it is only the Awesome Bar that isn't work.

How do I fix this?

Thanks in advance, everybody!

Chosen solution

sheesh, I gotta do everything around here--ask a question and then fix the problem?

1) Step 1) open uBlock settings > Dashboard > 3rd Party Filters: Purge all caches, then Update now.

2) Open Avira AV, go to advanced firewall settings, turn off Windows Firewall (apparently not the same as Windows Defender, which is already off), then turn it back on)

3) turn off Firefox ability to connect to the internet then turn it back on.

4) CLOSE (not restart) *then* Restart Firefox.

I don't know which step fixed it (I didn't do one-at-a-time trial-and-error trouble-shooting method), but it did. I never had this problem with Ad Blocker Plus...just sayin'...

Read this answer in context 👍 0

All Replies (6)

more options

Hi   !
That must be pretty annoying and frustrating !
Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Thanks for responding.

The Awesome Bar did work in safe mode.

However, *I* have not added, enabled, disabled, changed, or uninstalled any FF add-ons. In fact, last time I looked (before this problem), I think it was FF version 49.0.3 (or 49.3?). I didn't even know it had updated to version 50 on November 15, 2016 (or the 16th, I just know it's been updated in the last day or two).

This problem started directly after the FF update.

So this isn't a result of something that *I* did, of some change that I made to FF or anywhere on my computer--no Windows or other Microsoft updates, I haven't installed or uninstalled any new software or made any system changes.

Please help. Thanks.

more options

Of course it's not something   you   did;   definately not   !
I was about to suggest that you'd check a few things in 'about:config',   but you can't type anything in the address bar   .......
Maybe this will do the trick:
https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/
Keeping my fingers crossed   .......

more options

I wasn't saying that you, Happy112, were saying that I did something "wrong." I just wanted to make it clear that I haven't been screwing around with stuff and I inadvertently messed something up (which is usually the case both with myself and with other computer users).

However, how is this second possible solution from you going to help? Adding *another* Extension? And one that, from the description, is definitely not something that I want, it is something that will conflict with all of the other add-ons that I have carefully added and tested for compatibility into something approaching maximum effectiveness and some modicum of stability with absolutely no indication that it will have any effect on the problem that I am experiencing.

Got another idea?

Have there been no other reports of this issue following the latest FF update?

This really bites and is yet another computer frustration that I have little time to deal with. I've been a faithful FF user for many many years but I'm getting increasingly frustrated with FF. Add-ons seem to conflict more often than integrate with the other Add-Ons, and the Test Pilot ones almost always cause severe hang-ups (yes, I do understand that they are beta Extensions but so far, only Min Vid has worked without crashing FF).

more options

Chosen Solution

sheesh, I gotta do everything around here--ask a question and then fix the problem?

1) Step 1) open uBlock settings > Dashboard > 3rd Party Filters: Purge all caches, then Update now.

2) Open Avira AV, go to advanced firewall settings, turn off Windows Firewall (apparently not the same as Windows Defender, which is already off), then turn it back on)

3) turn off Firefox ability to connect to the internet then turn it back on.

4) CLOSE (not restart) *then* Restart Firefox.

I don't know which step fixed it (I didn't do one-at-a-time trial-and-error trouble-shooting method), but it did. I never had this problem with Ad Blocker Plus...just sayin'...

more options

Well done,   you   !
Sorry to have let you down;   apparantly my braincells aren't functioning as well as yours   ........
Would you be a dear and mark your last post as   Chosen Solution,   so others will know and might benefit from it   ?
Thank you   !