Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 44.0 Flash player not working

  • 13 replies
  • 16 have this problem
  • 4571 views
  • Last reply by rseiler

more options

I have Windows 10 Pro build 14251 and when my firefox update last time flash player not working. I try to reinstall flash player, also I try clean installation of flash player but player not working. Every sites with flash not working properly (I cant see flash content).

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions (3-bar Menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: 3-bar Menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with current Shockwave Flash plugin versions and hardware acceleration in Firefox and try this:

See also:

Read this answer in context 👍 1

All Replies (13)

more options

Hi coaboy, Thank you for your question. I understand that Flash player is not playing on a Windows 10 computer with Firefox. I am happy to help.

  • Does this happen on various sites? If not, check to make sure that the plugin is not blocked for that site in the permission settings. (Right click on the page and select "Page Info" -> Permissions tab)
more options

NO, every sites with flash banner, animation or video player based on flash not working. Also I try to disable hardware acceleration but same thing happening.

more options

Hi there.

Since you already checked the plugin permissions and hardware acceleration, this smacks of either interference or straight-up blocking. It could still be a playback issue, of course.

Interference could be coming from Quicktime. Does the issue remain if you disable/uninstall the Quicktime plugin?

I can't see AdBlock Plus or any other blocking add-ons in your UI. Are you using any content blockers or filters?

Lastly, do your other browsers work with the latest Flash plugin (when you install all their separate packages)?

more options

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions (3-bar Menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: 3-bar Menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with current Shockwave Flash plugin versions and hardware acceleration in Firefox and try this:

See also:

more options

@cor-el thanks a lot. Problem solved when I disable protected mode in the Flash.

more options

You're welcome.

more options

This is a problem here in the new 14257 build as well. There are numerous posts in the Windows Feedback tool about it, though they all still mention 14251 at this point.

Oddly, Protected Mode isn't a problem in some other Mozilla-based browsers that use the same plugin, such as Cyberfox, or non-Mozilla browsers that also use it, like Opera 12.

more options

Just as an update, neither 44.0.1 nor today's Flash 20.0.0.306 updates remedied this. Will report back with the next Windows build.

more options

No-go on 14271 (x64) and 44.0.2 (x86).

more options

No-go on 14279 (x64) and 45.0 (x86) RC2.

I'm beginning to wonder in which of the three (Flash included) the bug lies.

more options

No with 14316 (x64), Flash 21.0.0.197, and FF 45.0.1 (x86).

How long will this go on?

more options

Not working in FF 45.0.1 on Ubuntu 14.04 LTS either

more options

When this was fixed exactly I don't know, since I stopped checking, but Insider build 14385, plus Flash 22.0.0.209, plus Firefox 47.0.1 now work when Protected Mode is enabled.