Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

MSE & WebM VP9 causing my cpu at full load

  • 14 replies
  • 5 have this problem
  • 1956 views
  • Last reply by proud_greek

more options

hi guys i have a realy big problem as the title says when im going and enabling MSE & WebM VP9 because without it i cant watch all resolutions at youtube my cpu is at 100% even at a 1080p video with that disabled i can watch 4k videos with my cpu at 30-40% propably bcz hardwere acceleration is working? i have an r9 380 4gb with latest drivers thanks for help :)

Chosen solution

Normally I would suggest trying in Safe Mode to rule out Themes and Extensions, but as that turns off HWA, it's not really a solution here. Worth trying without Themes and Extensions enabled, though.

Read this answer in context 👍 1

All Replies (14)

more options

anyone please???

more options

Sorry that you haven't received an answer yet. Way beyond my expertise, but I do recommend that you check for updates for your graphics drivers and see if new drivers provide a resolution of your issues.

more options

the-edmeister said

Sorry that you haven't received an answer yet. Way beyond my expertise, but I do recommend that you check for updates for your graphics drivers and see if new drivers provide a resolution of your issues.

thank you for youre answer but i have everything latest :)

more options

still nothing......

more options

If the CPU is working so hard, hardware acceleration is most likely off. The whole point of it is to offload video to the GPU, which is more suited for handling the load. Curious that should only be the case for WebM/VP9.

To check, click the menu button (three bar sandwich), choose Options, select the Advanced panel, select the General tab, check Use hardware acceleration when available (if unchecked). Restart Firefox.

If going through the UI doesn't solve it, you might need to Refresh your Firefox settings - this has helped many people who upgraded to Windows 10, dragging along incompatible settings in their Firefox data.

Refresh: https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

I can see 40.0 had HWA and codec issues with Windows 10, but that is several versions back and the issue was since fixed.

more options

Chosen Solution

Normally I would suggest trying in Safe Mode to rule out Themes and Extensions, but as that turns off HWA, it's not really a solution here. Worth trying without Themes and Extensions enabled, though.

more options

alright guys first of all thank you for youre answers second the prob fixed my cpu is bit higher than vp9 disabled but its not the difference so big from vp9 disabled i have the latest beta mozilla 64 bit the probleme fixed thank you so much :)))) about 1 version back my cpu with vp9 enabled was at 100% even on 1080p videos :) now i can enjoy vp9 :D also my hardwere acceleration was always on

Modified by proud_greek

more options

You're welcome, glad to hear you're back on track!

I'll keep that in mind about suggesting the 64-bit build, as it seems to solve some issues people are having with 44.0.

more options

Phoxuponyou said

You're welcome, glad to hear you're back on track! I'll keep that in mind about suggesting the 64-bit build, as it seems to solve some issues people are having with 44.0.

can i ask a question again vp9 is more heavy than mp4 or what youtube was using? i cant watch 1440p videos on vp9 with mp4 i could watch 4k videos my cpu is still at 100% maybe vp9 is more heavy?

more options

i have flash player installed maybe that could be the problem?

more options

Firefox could use hardware based decoding for MP4 if your graphics display this supports, but will have to use software decoding for VP9.

You can check that in the graphics section on the about:support (Help > Troubleshooting Information) page.

more options

i found only that Supports Hardware H264 Decoding Yes i cant find anything related to vp9 WebGL Renderer Google Inc. -- ANGLE (AMD Radeon (TM) R9 380 Series Direct3D11 vs_5_0 ps_5_0) also i should also mention that vp9 is not by default enabled im going at about:config and enabling media.mediasource.webm.enabled

Modified by proud_greek

more options

WebGL Renderer Google Inc. -- ANGLE (AMD Radeon (TM) R9 380 Series Direct3D11 vs_5_0 ps_5_0) also i should also mention that vp9 is not by default enabled im going at about:config and enabling media.mediasource.webm.enabled

Modified by proud_greek