Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

MENU BAR IS ALL BLACK AND CAN'T READ ANY OF THE OPTIONS?

  • 12 risposte
  • 6 hanno questo problema
  • 9243 visualizzazioni
  • Ultima risposta di gabrio

more options

I loaded a new mozilla firefox after haveing trouble with the old one, after i loaded the new one the menu bar is all black and none of my old bookmarks are there? It is like the display background is black and the options (file edit view history bookmarks tools and help) are also black.

Soluzione scelta

hi

thanks for the reply, yes when i disable HW acceleration the problem goes away.

though i think i pinpointed the problem to new video drivers, probably the intel hd 3000 or new ATI drivers.

there's this issue when i have from the BIOS the graphic adapter set to "dynamic", similar problem with the latest Kazaa Codecs Pack. with that on to dynamic, there's a strange green frame at beginning of .mkv movies (DXVA), if i set to fixed, it looks normal.

and as for FF's issue, also IE9 does very same behaviour with black menus, in that case, black on the main page of search engines....

thanks anyway Gabrio

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (12)

more options

Did you uninstall Firefox and choose the option to delete your personal data? I hope not, so let's set that possibility aside.

What version of Firefox were you running before -- latest version or a much older one? What problem was it having?

I'm a little suspicious about your home page. I think it could indicate a malware problem with something called PrivitizeVPN and/or MagniPic. However, that's just a guess based on a web search for the searchou.com domain.


Messed up toolbar colors could be caused by an add-on or custom settings, or possibly by Windows' high contrast theme. If you haven't changed anything in Windows recently, let's try bypassing Firefox settings.

A standard diagnostic to bypass interference by extensions (and some custom settings) is to try Firefox's Safe Mode.

Restart Firefox in Firefox's Safe Mode (Troubleshoot Firefox issues using Safe Mode) using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode."

If Firefox looks normal, this would point to one of your extensions or custom settings as the problem.


If you have low tolerance for troubleshooting, you could try the Reset feature. This duplicates certain key data from your active settings folder into a new one, bypassing some add-ons and custom settings.

More information in this article: Refresh Firefox - reset add-ons and settings.


Let's loop back to the bookmarks problem after you explore the above.

more options

Some keyboard shortcuts if you can't use the menus:

  • Alt+F4 will exit Firefox
  • Holding the shift key when you launch Firefox (assuming there are no Firefox windows open) will display the Safe Mode dialog
  • Alt+h will open the Help menu, then r will select Restart with Add-ons disabled
  • Alt+h will open the Help menu, then t will open the Troubleshooting Information screen
more options

I did reset and now the menu and tab bar is not black anymore and i can now easly read ( file, edit, view, history, bookmarks, tools and help) What started my problum yesterday was that i lost some of the settings in my tool bar. and as a fyi i did have Magnipic but before i did any thing today i uninstalled it through control panals. When i installed the new version yesterday it did save my personal setting and bookmarks i believe in a folder now on my desktop , it is labeled old firefox data. Is there any way to recover my bookmarks from that folder, I had lot of web locations that were important to me in my bookmark. Thanks Steve

more options

Hi Steve, reset is supposed to copy your bookmarks automatically. You can restore them manually if needed. When you view the following article, note the choice at the bottom of the Restore menu which lets you navigate using Windows Explorer. You will go to that Old Firefox Settings folder, and inside you should find a folder called bookmarkbackups. Use the details view to see the file sizes in case the most recent is empty. Restoring a file from there will completely replace whatever you currently have, but presumably you haven't bookmarked a lot of sites in the past 24 hours.

Restore bookmarks from backup or move them to another computer

Any luck?

more options

The file called bookmarkbackup is there in the folder but when i open it for some reason it opens with microsoft office word. It really doesn't list the url addresses, is there another programe that i could open this file with that i then can import into the new mozilla aplication. Thanks Steve

more options

jscher2000 is probably not online at the moment

I apologise for the shouting but I am trying to emphasise the importance of the backups. :-)

BEFORE you attempt any restore (and again afterwrds) Please take CARE, always make a manual backup of your bookmarks and place them somewhere safe, outside Firefox program and profile paths: your desktop will do.

You do not need to look at the file, once you have decided it is appropriate. It is as you will have noticed largely plain text but will not make much sense in a Word Processor.

You need to use the Firefox Bookmarks Library to restore the file, you then see the full detail, BUT that overwrites your existing bookmarks which is the reason you need the manual backups. As long as you have backups you are able to try different files and then restore the best one.

more options

Thanks you for all the help and information! i was able to restore all my bookmarks by going to history left click -show all history left click- imports and backups left click- restore left click-choose file, I then restored them from the folder that was on my desktop from yesterday that had all the bookmarks in as bookmarks backup

more options

Glad we were able to help. Thanks for posting back.

more options

hello

i have just upgraded to the latest version of FF, 21.0 and i have the same problem, when i load it the first time, the menus appear all black, though if i hover over the links (even if i dont see them), then when i go there again, they appear OK.

problem does not seem to appear if i switch off hardware acceleration from options.

I have a HP dv6 with switchable graphics. problem occurs if i have the setting to "dynamic" (from bios) while if i force it to my ATI card, then it works OK.

interestingly, if i start the laptop with the ATI card (so fixed setting), and once is booted up i set to use the Intel HD3000 for FF, then FF works ok and no black happening.

this didn't happen with previous version i think 20.0 or 20.0.1 i think. yesterday i just updated the ATI video drivers, too.

see attached file.

Many thanks, Gabrio

more options

i tried to uninstall FF, reinstalled, nothing

started FF in safe mode (FF's safe mode), and works perfect, no black.

i tried to run normal and disable all the add-ons, but problem still occurs.

thanks, Gabrio

Modificato da gabrio il

more options

Gabrio,

Try disabling Hardware Acceleration in Firefox, to see if that helps.

https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_turn-off-hardware-acceleration

more options

Soluzione scelta

hi

thanks for the reply, yes when i disable HW acceleration the problem goes away.

though i think i pinpointed the problem to new video drivers, probably the intel hd 3000 or new ATI drivers.

there's this issue when i have from the BIOS the graphic adapter set to "dynamic", similar problem with the latest Kazaa Codecs Pack. with that on to dynamic, there's a strange green frame at beginning of .mkv movies (DXVA), if i set to fixed, it looks normal.

and as for FF's issue, also IE9 does very same behaviour with black menus, in that case, black on the main page of search engines....

thanks anyway Gabrio