Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Clearing chace on refresh not working anymore

  • 10 risposte
  • 1 ha questo problema
  • 36 visualizzazioni
  • Ultima risposta di jscher2000

more options

Hi,

I'm a web designer, I love firefox for develop my projects, one of the things that I love is that when i change a property value and I reload the page (F5) file css are ever updated,

Only in some cases with .js files I had to use ctrl+F5,

but now every modify I do then I hat to use ctrl+F5, why??

Tutte le risposte (10)

more options

I'm not aware that Firefox 79 made changed in this area (Developer Release Notes), but if needed, you can disable the disk cache:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste cache and pause while the list is filtered

(3) Double-click the browser.cache.disk.enable preference to switch the value from true to false

To change back later, return to this preference and double-click to toggle it back to true.

More info on about:config: Configuration Editor for Firefox.

È stato utile?

more options

I have tried to set the value to false of browser.cache.disk.enable but it's the same, I reload the page but the css are the same, only using ctrl+F5 it's updated.

I had think is a problem with the hosted file and VScode upload but at first saving the file is updated as always, I don't know if is a problem of wordpress but I have tried on two different sites and the problem is the same.

È stato utile?

more options

Maybe it's cached in memory? There is a separate setting that governs whether Firefox checks for updates to cached pages. You could try changing it from 3 to 1 and see whether it makes any difference for CSS files:

http://kb.mozillazine.org/Browser.cache.check_doc_frequency

È stato utile?

more options

Nothing it's the same, only with ctrl+F5 works

È stato utile?

more options

Hmm, when I use the Network Monitor to watch requests made while navigating a mini-site, I cannot see Firefox checking whether a CSS file has been updated when it is used again (it does check all the .js files every time). I've attached a screenshot illustrating.

To open the Network Monitor in the lower part of the tab, you can use either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

There's a tiny gear icon on the right side. Click that to open a menu and turn on Persist Logs (otherwise, the list clears after every reload).

When you reload the page, Firefox should start listing all the files it is requesting, along with information about whether the request was successful.

That seems weird, do you have time to search whether a bug has been filed? https://bugzilla.mozilla.org/

È stato utile?

more options

I don't know how works a browser, but I know that it's a behavior like chrome, before a some day when I was changing a simple color or a margin and I was reloading with F5 all are updated and now no,

In the network panel I have see that with F5 not reload the css file but only with ctrl+F5, I noticed a Deactivate cache button on this panel and with the tick on the box it works as before, but only if I have the panel open.

I'll check the bugs but for now it doesn't seem to be reported.

The strage thing is that by modifying the config file doesn't change anything.

Anyway there is a way to change F5 with ctrl++F5 for the moment?

Modificato da Alessio Paoletti il

È stato utile?

more options

Note that the developer tools have a setting (F1) to disable the HTTP cache while the tools are open.

Advanced settings:

È stato utile?

more options

I have noted but I talk without the F12 open, however I have set to false most of things on config file after searched "cache" and now when I reloading a page also update the css file.

But I don't know why there is this change of behavior in these days.

È stato utile?

more options

There was a change in Firefox 79 to allow caching stylesheets across documents (1599160). This skips the network request on reloads or loads of other documents in the same document group (unless caching is bypassed or disabled). There also was a hint that this may well happen for .js files in the future (1656405).

The checkbox that cor-el mentioned corresponds to this preference:

devtools.cache.disabled (checked => true)

I think that's the only one you need to modify to work around this issue, but if you have a high page weight, it's going to be a hassle. We need an easier workaround.

È stato utile?

more options

Hi Alessio, as another workaround, I created an extension you can use to temporarily prevent caching of CSS files from your own servers (or any servers, you create the host list and set the host permissions). Then the CSS files will always need to be retrieved when you use F5, but files that do not need to be updated can be used from cache.

(I'm still trying to figure out a good user interface for managing addition and removal of host permissions. Hopefully Firefox will have a native one at some point.)

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.