Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

<a href="#Contents">Contents</a> linking to <a name="#Contents"></a> in a standard HTML web page doesn't work. It does in Internet Explorer. What's wrong with F

  • 3 risposte
  • 1 ha questo problema
  • 3 visualizzazioni
  • Ultima risposta di wesleytilson

more options

I have several pages with internal links that work in Internet Explorer, but when tested in Firefox, they don't. Is there a security setting preventing this. Is there anyone out there for whom internal links work. Here is a link to a page I'm talking about:

http://thebooksofscripture.com/beowulf-by-gummere

Thanks.

I have several pages with internal links that work in Internet Explorer, but when tested in Firefox, they don't. Is there a security setting preventing this. Is there anyone out there for whom internal links work. Here is a link to a page I'm talking about: http://thebooksofscripture.com/beowulf-by-gummere Thanks.

Soluzione scelta

You have a link in this format:

<a href="#exactIdOrName">

In your document, your id or name attributes need to exactly match the text after the hash mark:

<a name="exactIdOrName">

Compare yours. Notice the extra character in your id or name attributes that breaks the link in Firefox?

Some other browsers have an attitude of "we know what the author meant" but Firefox is more literal. Remove the hash signs from your name attributes (not your href attributes) and try again.

Leggere questa risposta nel contesto 👍 0

Tutte le risposte (3)

more options

See this Validation Report for that webpage. https://validator.w3.org/nu/?doc=http%3A%2F%2Fthebooksofscripture.com%2Fbeowulf-by-gummere%2F

Probably relates to error#7 and below. The name attribute is obsolete. Consider putting an id attribute on the nearest container instead.

more options

Soluzione scelta

You have a link in this format:

<a href="#exactIdOrName">

In your document, your id or name attributes need to exactly match the text after the hash mark:

<a name="exactIdOrName">

Compare yours. Notice the extra character in your id or name attributes that breaks the link in Firefox?

Some other browsers have an attitude of "we know what the author meant" but Firefox is more literal. Remove the hash signs from your name attributes (not your href attributes) and try again.

more options

id attribute Thanks.