X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Foxit Reader Plugin for Mozilla 2.2.3.111 blocked while blocklist.xml tops out at maxVersion="2.2.1.530"

Posted

Attempting to open a .pdf with Firefox 18.0, and having Foxit Reader Plugin for Mozilla 2.2.3.111 installed, I receive the gray lego piece page with text "The plugin is vulnerable and should be updated/Check for updates/Click here to activate the Foxit Reader for Mozilla plugin"

I look into the blocklist.xml file and find the plugin item:

     <pluginItem  blockID="p250">
                 <match name="filename" exp="npFoxitReaderPlugin\.dll" />                      <versionRange  minVersion="0" maxVersion="2.2.1.530" severity="0" vulnerabilitystatus="2"></versionRange>
                 </pluginItem>


Next, I view installed plugins and find: Foxit Reader Plugin for Mozilla 2.2.3.111, and it is not disabled.

My first question is why, when the installed plugin version is 2.2.3.111, and the blocklist maxVersion is 2.2.1.530, do I receive any kind of plugin blocked page?

My second question is "is there any method or technique so specifically unblock a particular plugin, without affecting any other plugin?"

I force-reinitialized the blocklist.xml file and database.

Currently, I am running extensions.blocklist.enabled false, to sidestep this exact problem, but would definitely prefer to have this set true.

Thanks.

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Enables the interaction of Mathematica content with the latest installed version of Mathematica.
  • Shockwave Flash 11.4 r402
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • DivX VOD Helper Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DivX Web Player version 2.1.1.94
  • iTunes Detector Plug-in
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Plugin page information: Installed plugin version is 2.2.3.111, last updated Friday, January 11, 2013.
Actual plugin installation date: January 21, 2013.
about:plugins shows
File: C:\Program Files\Foxit Software\Foxit Reader\plugins\npFoxitReaderPlugin.dll
Version: 2.2.3.111
Foxit Reader Plug-In For Firefox and Netscape
MIME Type Description Suffixes
application/pdf Acrobat Portable Document Format pdf
application/vnd.fdf

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

See:

  • bug 828982 - Plugin block request: Foxit Reader Plugin 2.2.1.530 and below due to critical vulnerability

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

Helpful Reply

Hi cor-el,

I did see the bug report, that relates to 2.2.1.530 AND BELOW.

The current installed plugin is 2.2.3.111, which is ABOVE 2.2.1.530, hence the blocklist should not apply, since its setting "maxVersion", apparently the maximum version to which the block list should apply, is 2.2.1.530.

Thank your for looking into this, though.

Possibly I do not understand the maxVersion property in the .xml?