X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Foxit PhantomPDF for Mozilla Plugin Can't Update

Posted

When I seek to open a file http://www. ....xyz.pdf within Firefox 17.0.1, message "This plugin is vulnerable and should be updated. Check (here) for updates. Click here (anywhere on screen) to activate the Foxit PhantomPDF for Mozilla plugin."

When I go to site that supposedly has links to updates, it takes me to Mozilla's plug-in check page. On that page, to the right of "Foxit PhantomPDF Plugin for Mozilla" it says "Unknown plugin. If I select the "research" option, it opens Google search on the Foxit topic. The top link takes me to a Foxit FAQ page that doesn't seem to answer my question. It has links to an offer for a "trial" version of Foxit PhantomPDF reader, but I already have a licensed version of same although the licensed version does not specifically say it includes the plugin for Mozilla.

I've tried using the Firefox|Options|Applications to keep Firefox from opening "Foxit PhantomPDF Plugin for Mozilla"  and instead to use Adobe Acrobat 8.0 for opening Adobe Acrobat 7.0 documents.  Selecting Acrobat 8.0 or selecting "Always ask," (for all of the three Acrobat 7 items) doesn't stop Firefox from insisting on opening "Foxit PhantomPDF Plugin for Mozilla"  I have tried disabling the plug-in "Foxit PhantomPDF Plugin for Mozilla", but Firefox still insists on using it. 

b.t.w. I run Firefox on another WinXP SR-3 machine that does NOT have licensed copy of Foxit Phantom, and it willingly opens Internet based pdf documents with Adobe Acrobat Reader. I've been unable to get Adobe Acrobat Reader to install on my main machine perhaps because it believes the presence of the license version of Acrobat 8.0 makes the reader unnecessary.

I tried the manual disabler via "about:config" and went to: C:\Program Files\Mozilla Firefox\plugins and renamed the file with triple X's to this: XXXnpFoxitReaderPlugin.dll But FireFox still insists on using the Foxit Phantom Reader for Firefox


I don't know the nature of the plugin vulnerability, but I like to avoid any possible vulnerability. How do I kill the "Foxit PhantomPDF Plugin for Mozilla" or where do I find a compatible update?

Thanks in advance.

Chosen solution

Thank you ... that worked .. I don't know if PDF was or was not an option when I looked previously, but it was there this time, and by selecting Adobe to handle it, the files now open smoothly.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.10.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0
  • Winamp Application Detector
  • GEPlugin
  • Foxit PhantomPDF Plug-In For Firefox and Netscape
  • Foxit Reader Plug-In For Firefox and Netscape
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • NPWLPG
  • Motive Plugin for Mozilla Browsers
  • npmnqmp 989898989877
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • 1.7.0069.2
  • Keep your drivers up to date with Driver Agent. Designed for Firefox, Opera, Mozilla and Netscape; version 2.2006.11.20
  • Adobe PDF Plug-In For Firefox and Netscape
  • npsnapfish

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Operating system: WinXP pro with SR-3
Browser: Firefox 17.0.1
PDF Reader1: Foxit Reader version 4.2.0.0928 Used for quick read of pdf files
PDF Reader 2: Foxit PhantomPDF version 5.0.3.0811 Used to quickly password protect pdf files
PDF Reader 2: Adobe Acrobat 8 Standard Version 8.0.0 Used to edit .pdf files
CPU 3.0 GHz dual Pentium
Memory: 2 GByte RAM

finitarry 157 solutions 2178 answers

You could set Firefox to use Foxit as a helper application, rather than the plugin. Do that from Options > Applications.

Question owner

You suggest going to Options|Applications and specifying Foxit as a "helper application." I find no such option. On the left is listed the various applications. On the right, in pull down menu, as the options for opening files delineated on the left. There is a "helper" at ToolsDownLoad Helper, but I could not find anything to specify which application was to be used to open .pdf file in micro-soft window.

finitarry 157 solutions 2178 answers

Helpful Reply

In Options > Applications, look for Portable Document Format (PDF) and next to that should be pull-down menu. If you have a plugin that can handle it, there will be an item "Use [whatever] Plug-in", but there should also be an item that says "Use [whatever]". That last item is an application, not a plugin.

Chosen Solution

Thank you ... that worked .. I don't know if PDF was or was not an option when I looked previously, but it was there this time, and by selecting Adobe to handle it, the files now open smoothly.