Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox always prints webpage background color

  • 10 replies
  • 1 has this problem
  • 860 views
  • Last reply by Tim

more options

I have used two different computers and two different printers with same results. Printing works fine when printed from Internet Explore. Older versions of Firefox workfine. An example page is my home page http://www.dixonvision.com

All Replies (10)

more options

If you go to Page Setup is the option "Print Background" checked?

more options

No it is not checked

Modified by bigcrawdaddy

more options

Do you see the background when you go to Print preview?

I do not see the background being printed on my setup.

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile

more options

I have been printing from three different computers. All three with new installs of the latest versions of Firefox. Two of the three are new laptops running Windows 7, the third ia an old Windows XP desktop. All three have access to three network printers.

I spent many hours last night working on this issue and I think I found the issue but I know of no way to fix it.

I have low vision and so when using computers I set them into the High Contrast Mode. It is when the computers are in High Contrast Mode that Firefox prints the background of websites.

This was never an issue in Firefox before version 4. Maybe a fix for this will be in the next build.

more options

Does it help if you also disable the website colors, possibly only during printing?

  • Tools > Options > Content : Fonts & Colors > Colors : [ ] "Allow pages to choose their own colors, instead of my selections above"
more options

Sorry but not that has no effect at all. I'm not a normal pc user I know I have tried every setting it has been this way since version 4 of Firefox.

Maybe if someone would try the following they might get the same results as I do.

From a Windows XP or Windows 7 press Alt+Shift+Print Screen a box will come up asking if you want to use High Contrast, click Yes. Your screen will now have a black barckround and either witite or yellow text.

Now open Firefox 4,5,6,7 and go to http://www.dixonvision.com and print the page. I bet you get a black page with two photos.

more options

Found a bug report for Thunderbird - https://bugzilla.mozilla.org/show_bug.cgi?id=683139

more options

Thanks fmdeveloper now I know I'm not juts but others have these issues and it not only with xp but any version of windows and all versions of Firefox since version 4

more options

fmdeveloper can you add to that bug report the issue I'm having. I don't think they have looked at the link to this issue.

more options

The bug has been confirmed and will be assigned to someone to fix. They have identified the cause. If you want to keep up to date, vote for, or add yourself as a CC to the bug.