X
Tap here to go to the mobile version of the site.

Support Forum

Firefox does not completely shut down when X'd out, I have to do a restart to completly close the program, is this common?

Posted

I just upgraded from 5.0 to 6.0 and the upgrade program told me that Firefox had to be closed before the new version could be installed. I had already X'ed out Firefox knowing that it needed to be closed before I could do an install. I finally had to do a restart before I could install the new version. This has happened in the past with other versions of Firefox. Firefox keeps running in the back ground for some reason and ends up using resources that are needed else where. In the past I have deleted Firefox from my computer to solve the problem, can you solve the problem or should I delete the program and use another browser?

I just upgraded from 5.0 to 6.0 and the upgrade program told me that Firefox had to be closed before the new version could be installed. I had already X'ed out Firefox knowing that it needed to be closed before I could do an install. I finally had to do a restart before I could install the new version. This has happened in the past with other versions of Firefox. Firefox keeps running in the back ground for some reason and ends up using resources that are needed else where. In the past I have deleted Firefox from my computer to solve the problem, can you solve the problem or should I delete the program and use another browser?

Additional System Details

This happened

Not sure how often

This started when...

This has happened with past versions of Firefox though I have not reported it before.

Installed Plug-ins

  • np-mswmp
  • 12.0.1.660
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Shockwave Flash 10.3 r183
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60531.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Nitro PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0

More Information

I am using WIN 7 on an HP Pavilion dv4-1444dx Notebook PC that is current with all updates, both Microsoft and HP.

SafeBrowser 543 solutions 2390 answers

Must be the "hang at exit" problem. You already know how to do Step1; now just determine which Add-on (Extension or Plugin) is causing the problem.

  1. Stop the Firefox process:
  2. Why Firefox may hang:
  3. Use Firefox Safe Mode to find a problem with an Extension or Plugin:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Must be the "hang at exit" problem. You already know how to do Step1; now just determine which Add-on (Extension or Plugin) is causing the problem.<br /><br /> #Stop the Firefox process: #*[http://kb.mozillazine.org/Kill_application Mozillazine - Kill application] #*Windows 7 users click [http://www.techrepublic.com/blog/window-on-windows/reap-the-benefits-of-windows-7s-task-manager/2576 here] #Why Firefox may hang: #*[http://support.mozilla.com/en-US/kb/Firefox+hangs Firefox hangs] (see Hang at exit) #*[http://kb.mozillazine.org/Firefox_hangs Firefox hangs (Mozillazine)] (see Hang at exit and Closing Firefox properly) #*[https://support.mozilla.com/en-US/kb/Firefox+is+already+running+but+is+not+responding Firefox is already running but is not responding] #Use Firefox Safe Mode to find a problem with an Extension or Plugin: #*Don't check anything when entering Safe Mode, just continue #*If the problem does not occur in Safe Mode it is probably and Extension or Plugin causing the problem #*See: #**[[Safe Mode]] and [http://kb.mozillazine.org/Safe_Mode Safe Mode (Mozillazine)] #**[http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes Troubleshooting extensions and themes] #**[http://support.mozilla.com/en-US/kb/Troubleshooting+plugins Troubleshooting plugins] #**[http://support.mozilla.com/en-US/kb/Basic+Troubleshooting Basic Troubleshooting] '''If this reply solves your problem, please click "Solved It" next to this reply when <u>signed-in</u> to the forum.'''