X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox won't open pages that redirect

Posted

I found out the other day that Firefox will no longer open pages that redirect to somewhere else. For example, I was trying to open phpMyAdmin through my hostgator account, and it just sort of "hung" there at the page where it said it was being redirected. I have since noticed it does it EVERY time a page needs to redirect to another page. If there is no link saying "click here if the page does not redirect" I just can't get it to work. I have had to resort to using IE for these sites!! I haven't a clue what's happened, as I haven't changed any settings at all.

This happened

Every time Firefox opened

== It started a few days ago for no apparent reason.

Additional System Details

Installed Plug-ins

  • -np-mswmp
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • Default Plug-in
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • 3.0.40624.0
  • NPWLPG
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

I can't find any troubleshooting information for it...Maybe I don't know what I'm searching for?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

See: Tools > Options > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

See Advanced settings for accessibility, browsing, system defaults, network, updates, and encryption

See also http://kb.mozillazine.org/accessibility.blockautorefresh

Modified by cor-el

Question owner

Thanks for that! I had already checked there but it never occurred to me to check the box to warn me... simply because I never had to do that before! (Before, it used to just redirect with no prompting). However, at least now I can click on Allow.

Nevertheless, does anyone know why this happened in the first place? I never used to have to allow it, it just DID it without prompting.

Still, at least I no longer have to use IE ;)

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You're welcome.

It may have been changed by an extension (Tools > Add-ons > Extensions) that updated recently. --- I noticed that your plugins list shows an outdated Java plugin with known security and stability risks.

# Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers

Update the Java plugin to the latest version. See http://java.sun.com/javase/downloads/index.jsp#jdk (you need JRE)

Question owner

I have same problem and followed instructions above and the only way a redirection will occur is by ticking the "warn me when a site tries to redirect". Is there any way to fix this issue without having to allow each redirect?

Thanks,

Rick

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

If that box is un-checked then you do not get a warning and Firefox will redirect automatically without asking for confirmation. That setting is meant as an accessibility feature to avoid confusion for users with disabilities in the location suddenly changes. It is not meant as a security precaution.

See also http://www.w3.org/TR/UAAG10-TECHS/guidelines.html#tech-configure-content-retrieval

http://en.wikipedia.org/wiki/Web_accessibility http://en.wikipedia.org/wiki/Accessible_Rich_Internet_Applications (ARIA)

Question owner

Cor-El:

I did have the "warn me" however with it unchecked it will not redirect to hostgator PhpMyAdmin. The only way it will redirect is by checking the box. I was looking for a way to have it redirect without getting message that allows me to get the redirection.

Thanks,

Rick

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions. You have to close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Question owner

Hi Rick,

I'm the original poster of the question, and like you, if I didn't have the box checked it wouldn't redirect at all (I found out it wasn't just phpMyAdmin, but every other site where it needed to redirect).

So far, I've fixed it by checking the box that allows me to redirect, but haven't fixed it beyond that (although it used to work just fine without clicking anything).

I will also try the fixes recommended to see if I can get it to redirect without clicking "allow".

Fiona

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Are you using NoScript?

If you have the NoScript extension then update to the latest version. See also http://noscript.net/changelog

Question owner

No I am not using the NoScript extension

Thanks,

Rick

Question owner

I have a similar problem when connecting to AirG chat via my computer with Mozzila Firefox version 3.6

http://airg.com or msnmobile.airg.ca

The following information comes up:

The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

  • This problem can sometimes be caused by disabling or refusing to accept cookies.

How can I fix it?

Kyle

Question owner

I have the same problem using Firefox 3.6.6. Have already checked:

  • Warn me when web sites try to redirect or reload the page (not selected)
  • accessibility.blockautorefresh (false)
  • cookies (enabled for the sites I'm trying to access)
  • NoScript (not using)

Other suggestions?

billdom 0 solutions 2 answers

Have checked "warn on redirect". Have disabled all add ons. Firefox will not redirect at all. 'Try again' just gives the same message.

We use redirects in our internal security system. We are having to use IE because of this problem. Please fix whatever was recently changed to cause this.

billdom 0 solutions 2 answers

Same problem with Chrome (duh). Error message from chrome makes me think that the problem has to do with pre-loading links/redirects when loading a page. Our system will often call a login page from a working page (if the user is not logged in) and the login page will redirect back to the calling page after the login occurs. Error message implied it was jumping back and forth between the calling page and the login page without ever showing either page. It eventually clocks out because it looks like a never ending loop to firefox.

BryanWatson 0 solutions 1 answers

I came across this issue recently, and found that an add on was causing the problem.

The add on was Tabs Open Relative (Modified) https://addons.mozilla.org/en-US/firefox/addon/tabs-open-relative-modified/

Disabling this add on was the solution, so hopefully this can lead a few others in the right direction.

Jeff Cohan 0 solutions 3 answers

I finally found the solution which works for me. Maybe this will help you.

(The culprit was the webdeveloper.meta.redirects.disable preference.)

Solution:

  1. Enter "about:config" in your location bar to access Firefox preferences.
  2. Find the above preference.
  3. If set to "true" (it was for me), double-click the row to toggle to "false".
  4. Voila!

I've only tested one site that was not redirecting (PayPal account login), but I'm happy to say all is right again.

HTH.

Jeff Cohan

emanuensis 0 solutions 2 answers

my culprit was: RequestPolicy 0.5.20

Ronv777 0 solutions 6 answers

Helpful Reply

Thank you Mozilla for protecting me. I do like the fact that Firefox 4 stops pages from automatically redirecting me, BUT IF I decide that I want to allow a page to redirect me why can't you fix it so that it remembers to do so next time?

If I uncheck this box: Tools > Options > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page, then I don't get redirected at all, which means that I can't use my on-line bank web page. If I check it then I have to click allow each and every time I change views on my register. I have had to click it as many as 108 times in one session. And that is the number of times that I counted. I tried to remember to put a mark down for each time I had to click allow, but I might have missed a few. This is becoming very annoying. When will it be fixed?

You have lists cookies, add-ons, passwords, pop-up windows, load images, I don't think one more list will cause Firefox to come crashing to a halt.

Just my 22¢ (inflation) :)

jeevan.joseph 0 solutions 1 answers

I was getting a warning message before each page loaded. To disable that did this

Solution:

  1. Enter "about:config" in your location bar to access Firefox preferences.
  2. Search for the preference : network.http.prompt-temp-redirect .
  3. If set to "true" (it was for me), double-click the row to toggle to "false".
  4. Presto !
Ronv777 0 solutions 6 answers

Didn't do anything for me.