X
Tap here to go to the mobile version of the site.

Support Forum

Firefox won't open pages that redirect

Posted

I found out the other day that Firefox will no longer open pages that redirect to somewhere else. For example, I was trying to open phpMyAdmin through my hostgator account, and it just sort of "hung" there at the page where it said it was being redirected. I have since noticed it does it EVERY time a page needs to redirect to another page. If there is no link saying "click here if the page does not redirect" I just can't get it to work. I have had to resort to using IE for these sites!! I haven't a clue what's happened, as I haven't changed any settings at all.

This happened

Every time Firefox opened

== It started a few days ago for no apparent reason.

I found out the other day that Firefox will no longer open pages that redirect to somewhere else. For example, I was trying to open phpMyAdmin through my hostgator account, and it just sort of "hung" there at the page where it said it was being redirected. I have since noticed it does it EVERY time a page needs to redirect to another page. If there is no link saying "click here if the page does not redirect" I just can't get it to work. I have had to resort to using IE for these sites!! I haven't a clue what's happened, as I haven't changed any settings at all. == This happened == Every time Firefox opened == It started a few days ago for no apparent reason.

Additional System Details

Installed Plug-ins

  • -np-mswmp
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.2"
  • Default Plug-in
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • 3.0.40624.0
  • NPWLPG
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

More Information

I can't find any troubleshooting information for it...Maybe I don't know what I'm searching for?

hudef 0 solutions 1 answers

I am using Firefox 3.6.21(due to needing compatibility to the gmail "offline mail" feature. There is no webdeveloper.meta.redirects.disable preference in my about:config. Nothing starting with webdeveloper at all, in fact.

I am so fed up with having to use Internet explorer to connect to wifi at my local library, McDonalds etc. I recently installed a dual boot of linux and so can't get on public wifi there at all, as there is no IE on linux.

When will Firefox developers (and chrome guys too) address this extremely common and extremely annoying well known issue????

I am using Firefox 3.6.21(due to needing compatibility to the gmail "offline mail" feature. There is no webdeveloper.meta.redirects.disable preference in my about:config. Nothing starting with webdeveloper at all, in fact. I am so fed up with having to use Internet explorer to connect to wifi at my local library, McDonalds etc. I recently installed a dual boot of linux and so can't get on public wifi there at all, as there is no IE on linux. When will Firefox developers (and chrome guys too) address this extremely common and extremely annoying well known issue????
Ronv777 0 solutions 6 answers

Hello everybody,

I have been dealing with this problem for almost a year now. I have finally figured out a way to fix this problem.

Now please understand I am a diehard Fox fan. I started using FF back in late 2002, I think it was called Phoenix at the time. It was in beta. So you can see that I don't offer this solution lightly. But I have had to use this solution for almost a year to access my on-line banking, my wife's on-line store website, and a myriad of other sites.

The solution is go back to IE.

You ask why will this work?

Well for one thing IE doesn't have this problem. It will redirect you to a page with no warning at all. Now I will admit that may not always be a good thing, but I have always been a believer in controlling my own life.

Two, if enough people stop using Firefox, then the developers will possibly get off their duff and start fixing the problems the Firefox community points out.

So for now I for one will uninstall Firefox. I will keep a watch on this thread and if something changes I may try Firefox again. But I hope it is soon, Who knows I may start liking IE to the point I will never come back.

Ron

Hello everybody, I have been dealing with this problem for almost a year now. I have finally figured out a way to fix this problem. Now please understand I am a diehard Fox fan. I started using FF back in late 2002, I think it was called Phoenix at the time. It was in beta. So you can see that I don't offer this solution lightly. But I have had to use this solution for almost a year to access my on-line banking, my wife's on-line store website, and a myriad of other sites. The solution is go back to IE. You ask why will this work? Well for one thing IE doesn't have this problem. It will redirect you to a page with no warning at all. Now I will admit that may not always be a good thing, but I have always been a believer in controlling my own life. Two, if enough people stop using Firefox, then the developers will possibly get off their duff and start fixing the problems the Firefox community points out. So for now I for one will uninstall Firefox. I will keep a watch on this thread and if something changes I may try Firefox again. But I hope it is soon, Who knows I may start liking IE to the point I will never come back. Ron
son0fhobs 1 solutions 7 answers

Greetings!

To those who are having trouble with it: in the about:config, search for redirect. Try turning the appropriate boolean settings to true (trial and error in necessary), and make sure redirect limit (an integer) is set relatively high (mine is 20 be default). If that doesn't work, search for a redirect plugin. Even if it's a blocker, it might be able to adjust the setting for you.


So firefox works fine for me 90% of the time. However, there's one site that pitches a fit when it won't redirect. Unfortunately, it's at Caribou when I'm trying to get into the public wifi. For now, I login via chrome then go back to FF, but that's a pain to say the least.

However, I don't every site to redirect. Is there any way to have a white list?

Or do any redirect prevention addons allow that feature?

I would imagine that I could make a very ugly hack with greasemonkey, but that's last resort.

Thanks all!

Greetings! To those who are having trouble with it: in the about:config, search for redirect. Try turning the appropriate boolean settings to true (trial and error in necessary), and make sure redirect limit (an integer) is set relatively high (mine is 20 be default). If that doesn't work, search for a redirect plugin. Even if it's a blocker, it might be able to adjust the setting for you. So firefox works fine for me 90% of the time. However, there's one site that pitches a fit when it won't redirect. Unfortunately, it's at Caribou when I'm trying to get into the public wifi. For now, I login via chrome then go back to FF, but that's a pain to say the least. However, I don't every site to redirect. Is there any way to have a white list? Or do any redirect prevention addons allow that feature? I would imagine that I could make a very ugly hack with greasemonkey, but that's last resort. Thanks all!
mdmoss87402 0 solutions 1 answers

I was having the same problem and I followed two posts from this page. I set the network.http.prompt-temp-redirect to false, and then I unchecked the box: Tools > Options > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page." It works fine now.

I was having the same problem and I followed two posts from this page. I set the network.http.prompt-temp-redirect to false, and then I unchecked the box: Tools > Options > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page." It works fine now.
desertheat 0 solutions 1 answers

I tried some of the stuff already mentioned. Then, in a fit of desperation, I pulled down on the help menu at Firefox and Restarted it with Addons Disabled. I was then able to quickly access the site that Firefox would not redirect me to. Then, I restarted Firefox, with all the stuff added back on, and I could still access the problem site. Broke the ice? I don't know, but it was simple and it worked.

I tried some of the stuff already mentioned. Then, in a fit of desperation, I pulled down on the help menu at Firefox and Restarted it with Addons Disabled. I was then able to quickly access the site that Firefox would not redirect me to. Then, I restarted Firefox, with all the stuff added back on, and I could still access the problem site. Broke the ice? I don't know, but it was simple and it worked.