Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address Bar Update

  • 12 replies
  • 2 have this problem
  • 29 views
  • Last reply by jscher2000

more options

Hello, thanks in advance for assistance. I absolutely despise this address bar pop out thing that was added for some odd reason. I searched for a way to remove it, found a solution that involved turning these to false: browser.urlbar.openViewOnFocus browser.urlbar.update1 browser.urlbar.update1.interventions browser.urlbar.update1.searchTips It solved my problem, had the bar back to the way I wanted it the day after the update rolled out and its been fine up to this point. Today, I'm using Firefox and the browser closed abruptly, so I clicked to reopen it and get an update. Once its done that awful bar is back again and its telling me to send a crash report. I send the report then go to reapply the solution I used before only to see that they are all still set to false but that bar is still popping out and my easy access drop down of sites I visit most is gone. Please, can anyone help me get rid of this bar. I've tried restarting the browser and no luck. I need a way to return it to how it was, I've tried using the new address bar, don't like it, and I do not want it at all. Again, thanks for any assistance.

All Replies (12)

more options

hello

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

  • browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

  • browser.urlbar.update1
  • browser.urlbar.update1.interventions
  • browser.urlbar.update1.searchTips

Then close and restart Firefox.

i hope resolved your problem then reply back to me,

Thank you

Helpful?

more options

ARMAN KHAN said

hello Would you do this please...

That worked on versions 75 and 76, but not on the latest version 77.

The answers on this thread show how you can use userChrome.css to reverse the "expanding address bar" behaviour in version 77:

https://support.mozilla.org/en-US/questions/1289351

Helpful?

more options

You need to use code in userChrome.css to revert the resize change made to the location bar because the related browser.urlbar.update1 prefs are no longer supported in Firefox 77 and later.


See also:

Helpful?

more options

Hello sessakag,

I've got my old address bar back (for now ... ) by creating this boolean preference on the "about:config" page an setting its value to   "true":

browser.urlbar.disableExtendForTests

Also see one of my favorite sites for more tips :

https://www.askvg.com/tip-new-working-method-to-disable-enlarging-address-bar-in-mozilla-firefox/

Helpful?

more options

Note that using browser.urlbar.disableExtendForTests = true is meant for automated testing purposes where you do not want the megabar features and isn't recommended.

This only sets #urlbar{height:100%} and that will prevent the location bar drop-down list from working properly (it can't expand beyond the height of the navigation toolbar) and thus can give weird effects if you use cursor down.

Helpful?

more options

cor-el said

Note that using browser.urlbar.disableExtendForTests = true is meant for automated testing purposes where you do not want the megabar features and isn't recommended.

This only sets #urlbar{height:100%} and that will prevent the location bar drop-down list from working properly (it can't expand beyond the height of the navigation toolbar) and thus can give weird effects if you use cursor down.

Good point !

I only use the address bar to enter URL's   (keyword.enabled = false, etc.),   but it might give others this weird effect you mention.

Helpful?

more options

So creating the chrome file worked, no more enlargement thank goodness but I also don't have the drop down I used to have. Is there a css file for that, because that's what I've been trying to get back. Thank you guys so much for your help so far!

Helpful?

more options

sessakag said

So creating the chrome file worked, no more enlargement thank goodness but I also don't have the drop down I used to have. Is there a css file for that, because that's what I've been trying to get back. Thank you guys so much for your help so far!

Do you still have browser.urlbar.disableExtendForTests set to true? If so, does switching it back to false (or deleting the preference completely) bring back your dropdown?

Helpful?

more options

Okay, I switched it to false and the drop down is still missing. I will delete it completely. One second.

Helpful?

more options

Deleted it, still missing the drop down arrow.

Helpful?

more options

sessakag said

Deleted it, still missing the drop down arrow.

The "Show History" button was removed. To summon the classic list, you can type a space into the bar. Can you get used to that?

Helpful?

more options

Also, if you changed the maxRichResults to zero as mentioned in the article, that needs to be edited to the number of suggestion rows you actually want.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.