X
Tap here to go to the mobile version of the site.

Support Forum

Windows toolbar will no longer show with firefox 69 running.

Posted

Running Windows 7 and firefox decided to update to firefox 69.0. Now that it did the windows tool bar will no longer pop up when I hover over where it should unless I close firefox.

Running Windows 7 and firefox decided to update to firefox 69.0. Now that it did the windows tool bar will no longer pop up when I hover over where it should unless I close firefox.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Hi don5441, if I understand correctly, you have your Windows 7 Taskbar set to "auto hide" so it doesn't show unless you hover over it? And Firefox blocks it?

Is your Firefox in full-screen view? Usually the F11 key can switch you in and out of full screen view.


If it's not that, perhaps the Firefox settings file that stores window dimensions has become corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename xulstore.json to something like xulstoreOLD.json. If you see a file named localstore.rdf, you can delete it.

Start Firefox back up again. Do windows display normally again?

That mini-reset will hide the menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.

Hi don5441, if I understand correctly, you have your Windows 7 Taskbar set to "auto hide" so it doesn't show unless you hover over it? And Firefox blocks it? Is your Firefox in full-screen view? Usually the F11 key can switch you in and out of full screen view. ---- If it's not that, perhaps the Firefox settings file that stores window dimensions has become corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''xulstore.json''' to something like xulstoreOLD.json. If you see a file named localstore.rdf, you can delete it. Start Firefox back up again. Do windows display normally again? ''That mini-reset will hide the menu bar and bookmarks toolbar.'' You can use one of these methods to show the toolbar list and select the desired bars there: * right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button) * (menu bar) View > Toolbars<br><em>On Windows, tap the Alt key to activate the menu bar temporarily.</em> * in Customize mode > Toolbars button (see: [[Customize Firefox controls, buttons and toolbars]]) To turn on the Bookmarks Toolbar, Menu Bar, or other bars, click it on the list.
Was this helpful to you? 0
Quote

Question owner

Thanks but none of that helped and as seems to be usual with ff and updates a lot of things are now broke. My form fillers no longer work, my bookmarks have all left the building and widevine continues to not work with Amazon videos. I know how to do all that you mention and I am tired of having to do it every update and a lot of it no longer fix's things anyway. Opera is becoming our go to browser of late and so far we have not had any problems there.

Thanks but none of that helped and as seems to be usual with ff and updates a lot of things are now broke. My form fillers no longer work, my bookmarks have all left the building and widevine continues to not work with Amazon videos. I know how to do all that you mention and I am tired of having to do it every update and a lot of it no longer fix's things anyway. Opera is becoming our go to browser of late and so far we have not had any problems there.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

Perhaps we should itemize the issues in more detail, if you want to pursue them here:

(1) Windows Taskbar Autohide -- doesn't unhide when hovered in Firefox 69

  • ruled out fullscreen
  • ruled out corrupted xulstore.json by creating a new one

Does it make any difference whether the Firefox window is maximized or resizable?

(2) Form fillers no longer work

Do you mean the built-in features (form history, address autofill), or an add-on? What have you tried so far?

(3) Bookmarks missing

Could you review: Recover lost or missing Bookmarks

(4) Amazon/Widevine

Continue in your thread here: https://support.mozilla.org/questions/1267677

Perhaps we should itemize the issues in more detail, if you want to pursue them here: (1) Windows Taskbar Autohide -- doesn't unhide when hovered in Firefox 69 * ruled out fullscreen * ruled out corrupted xulstore.json by creating a new one Does it make any difference whether the Firefox window is maximized or resizable? (2) Form fillers no longer work Do you mean the built-in features (form history, address autofill), or an add-on? What have you tried so far? (3) Bookmarks missing Could you review: [[Recover lost or missing Bookmarks]] (4) Amazon/Widevine Continue in your thread here: https://support.mozilla.org/questions/1267677
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.