Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When clicking another tab Firefox auto refresh it

  • 6 replies
  • 1 has this problem
  • 88 views
  • Last reply by cor-el

more options

Most of time when I switch to another tab, it will refresh it. Even it was reloaded ~5 second ago.

Made clean install and triend safe mode, but no help.

All Replies (6)

more options

Hello Yufina,

That must be annoying ....

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar :

accessibility.blockautorefresh

and make sure its value is set to true

If you had to change the value, then close and restart Firefox.

'Hope this helps .....

more options

Firefox shouldn't suspend tabs that quickly.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

See also the about:memory page.

more options

No help with those.

more options

Yufina said

No help with those.

Maybe you could switch to the release Firefox version (66.0.2) ......

more options

It seems that Firefox version 66.02 is ok, after quick look. So problem seems to be in 67.

EDIT: Same thing happening with Nightly

Modified by Yufina

more options

Be cautious with using the same profile with different Firefox versions, especially nightly builds, as this can easily make a profile incompatible with older Firefox versions like release or cause problems when at a later time Firefox 67/68 becomes the release version.