Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-ons Manager page is blank

  • 13 replies
  • 3 have this problem
  • Last reply by JayShankar

more options

I don't know if its the latest update (65.0.1) that did this to me since I don't know when I last went to the page, but when I go to Add-Ons Manager now, all I see is a blank page (or rather rows of white tiles) rather than a list of my add-ons that I can click on to modify/remove etc.

Any suggestions?


All Replies (13)

more options

Hi prouss, If you restart Firefox in Safe Mode, does the problem still occur? To start in Safe Mode, go to Help > Restart with Add-ons Disabled.

If the problem does not occur in Safe Mode, then you can disable your extensions one-by-one until you find out which one is causing the problem. For more info, visit Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems.

more options

Thanks, I tried your approach and (a) the problem did not occur in Safe Mode but (b) disabling extensions one by one did not solve the problem in normal mode. So I'm still unsure what could have caused this issue to arise (my extensions haven't changed since I was last able to see Add-Ons properly, all I've done is update FF a couple of times).

more options

There are a few other things that Safe Mode does.

One is that is ignores any scripts you have personally created to customize Firefox. If you have created a user.js file, userChrome.css file, or userContent.css file, those are ignored in Safe Mode. If you have set up any of those files, one of them may be causing the problem.

Another thing Safe Mode disables is hardware acceleration. To check if hardware acceleration is the cause of your problem, go to Preferences > General, and uncheck Use recommended performance settings, then uncheck Use hardware acceleration when available and restart Firefox.

Safe Mode also uses a separate file for your user-interface. To reset this, you'll need to refresh Firefox. This will purge a lot of your Firefox files, while retaining most of your personal data. For instructions, check out the following article: Refresh Firefox - reset add-ons and settings

If the cause was any of the above, please let us know which one.

more options

I did make a change to the userChrome file (to move tabs down below the address line) but I've tried going back to the original, which I'd saved, and I still have the problem.

I've tried unchecking the hardware acceleration box.

I haven't tried a refresh yet but I suppose I have to next. Does that reset the userChrome file too?


more options

Old userChrome.css code may still cause the problem, so let's be certain. Could remove the userChrome.css file from your profile, then restart Firefox?

If the problem is still there, you can re-insert it into your profile after you performed a refresh.

more options

Are you using the default theme?

more options

So frustrated with FF right now! I've lost track of everything I've tried today but nothing really worked and I ended up reinstalling the whole thing.

Now the Add-on page is fine but I can't get the tabs on the bottom any more, even with the changes to the userChrome file that worked before. (I did save the revised css file but I got some odd side effects when I tried using it after a refresh - like the red/yellow/green buttons moved from the top left corner to below the address bar which drove me crazy.) And my new installed profile folder doesn't have a chrome folder for me to get a completely fresh css file. Aaaaaargh.

more options

We'll see what we can do about getting your CSS back up and running.

Could you please share the content of your userChrome.css file, and what each script is meant to accomplish? There may be updated versions that will work with the latest version of Firefox.

more options

My old css file somehow accumulated over the years. I'd never paid it any attention until recently when I added script I obtained on these forums to put tabs at the bottom. So I couldn't tell you what any of it is there for, and as far as I'm concerned I'd be happy to start again from scratch.

Do you think it would work if I just create a new userChrome.css file in a chrome folder in my Profile and add the tabs script there and nothing else? ie does there need to be anything else in the css file? Other than the tabs issue, I'm perfectly happy with the way FF looks now.


more options

See this thread for updated userChrome.css code for Firefox 65 to move the tabs to the bottom position.

more options

prouss said

Do you think it would work if I just create a new userChrome.css file in a chrome folder in my Profile and add the tabs script there and nothing else? ie does there need to be anything else in the css file?

That's up to you, and what you want. If you're looking for recommendations, I recommend not creating a userChrome.css file at all, and using tabs in their default place.

But if you still want it, cor-el recommended a good thread. ☺️

more options

I think I've reached and exceed my level of competence when it comes to chrome! Thanks for the suggestions, I decided to live with tabs on top since anything I tried seemed to mess other things up one way or another.

(I did score one little victory though - I found script in one of these discussions to add color to the bookmark folders and got it to work, so my education here in chrome wasn't entirely wasted!)

Appreciate your help and patience.

more options

This thread seems to be active, so just in case it helps, here's my experience: After upgrading to Quantum (v. 65/66) I had exactly the same result with blank entries in the Add-ons Manager, although the add-ons themselves were working. Likewise, starting in safe mode revealed them successfully.

The culprit in my case was in my profile's chrome folder where I had installed a github custom css tweak, specifically the userContent.css file in that folder. The solution was very simple and painfully obvious: edit that file manually using textedit and comment out (/*) any lines containing "aboutaddons/addonlists". ... Voila! problem solved, the Add-ons Manager is back to normal.

I hope this helps anyone who might have the same problem originating in the chrome folder.