Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Last page visited open instead of home page!

  • 11 replies
  • 1 has this problem
  • 41 views
  • Last reply by McCoy

more options

When i open the Browser it opens to the last page i visited, I have been to menu and looked for the home page and it is still set to open?

All Replies (11)

more options

Hello MASTERSERV,

Just to make sure, would you please check this setting :

3-bar menu (or Tools) => Options => General

Under "Startup" - make sure that "Restore previous session" is unchecked.

If that option is checked, Firefox won't open your homepage at startup.

more options

I have checked that many times now!

more options

MASTERSERV said

I have checked that many times now!

From you original post I gathered that you only checked your homepage setting - sorry .....

When you're done browsing, how do you close Firefox  ?

Either : 3-bar menu => "Exit" at the bottom  ?

Or press Ctrl + Shift + Q on your keyboard  ?

Other  ?

more options

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title ba to make sure Firefox closes properly.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

Session restore set to true changed to false,seems to be working,,,Thank You

more options

Sorry, But now it is still acting the same...going back to last page visited

more options

MASTERSERV said

Sorry, But now it is still acting the same...going back to last page visited

I asked you before : how do you close Firefox  ?


You could delete or rename the user.js file in your profile folder and then restart Firefox.

Also take a look at this article :

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Modified by McCoy

more options

Not the same page, Just the last page i was on. And i said the red X upper right hand corner as i have been doing for years!

more options

Toggling browser.sessionstore.resume_session_once pref to false on the about:config page won't work. You need to remove user.js or at least remove the in the file.

Is there more content in user.js apart from this line as that might give a clue how this file was created?

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

Note that the "Help -> Troubleshooting Information" (about:support) page shows whether there is a user.js file present in the profile folder.

more options

MASTERSERV said

And i said the red X upper right hand corner as i have been doing for years!

I don't see you mention it, hence I asked (again).


As it must be confusing having two people giving you different suggestions, I'll back off and leave you in the capable hands of cor-el.

Modified by McCoy

more options

McCoy said

You could delete or rename the user.js file in your profile folder and then restart Firefox.
Also take a look at this article :
https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Just have to ask : did you try the above  ?