Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

reCaptcha not working

  • 3 replies
  • 11 have this problem
  • 883 views
  • Last reply by cor-el

more options

Firefox 47, Windows 7 Pro on slow dialup internet connection, Avast Antivirus previously and AVG Free antivirus now, Website first noticed the problem on is RewardSurvey.com in the last two months (it had been working fine) , no parental control, have tried starting Firefox in safe mode, don't know if it's related but have had Flash problems, too.

reCaptcha says to "update to a compatible browser"

All Replies (3)

more options

I also have the same problem on IE 11. I continue to have the same problem even after trying all the above fixes on both browsers. Any more ideas I can try? Is it possible that having the two browsers loaded though not active at the same time could cause this? I know Avast and AVG Free won't play nicely on the same system even if one is inactive.

more options

Multiple browsers shouldn't be a problem -- most people who have Firefox have at least one other browser (IE on Windows, or Safari on Mac), and often more (e.g., Chrome, Opera...).

The message to update to a compatible browser is unusual. It might be based just on how Firefox is identifying itself or it could be based on something being blocked that the site is trying to use. Since this affects multiple browsers, could it be something your security software is filtering out?

more options

If you use extensions ("3-bar" menu button or Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure such extensions do not block content. There is security software that can interfere with loading content, so check that as well.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools > Add-ons > Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window