Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do i fix my home page image suddenly stopped showing up and i have just a blank page?

  • 5 replies
  • 1 has this problem
  • 125 views
  • Last reply by cor-el

more options

due to slowness of loading, i was reloading my home page....repeatedly, i'm afraid. now, not only does my home page image not show up, but it's not even asking me if i wanna set a cookie. not sure why this is. works on my ipad, my friends' browsers (PC/mobile), my husband's ipad and mac laptop...i've looked around in options and on help forums and can't even find anyone else having this problem. seems like firefox isn't talking to my web hoster? dunno. 41.0.1 version. i'll try updating now. maybe that'll fix it. anyway, thanx for any help anyone can give.

Chosen solution

What are you using as a home page?


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Security Issue: Update your Flash Player Version 19.0.0.207
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Read this answer in context 👍 1

All Replies (5)

more options

Chosen Solution

What are you using as a home page?


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Security Issue: Update your Flash Player Version 19.0.0.207
https://www.adobe.com/products/flashplayer/distribution3.html
Note: Windows users must download the “Internet Explorer” and “Plugin-based browsers” installers.

Note: Edge on Win10 does not use ActiveX version but its own Flash.

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

thank you very much, FredMcD. starting it in safe mode has fixed my problem however, i'm curious as to what could've caused it in the first place. again, thank you so much!

more options

Safe Mode is not a cure. It helps us to find the source of the problem.

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

more options

thank you again. the only add-on i have is for my security software and it's already disabled. sooo...i'm at a loss!

more options

Starting once in Safe Mode may have triggered a re-initialization of the profile.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window