Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get this to stop: "Yahoo is the preferred search engine for Firefox. Switch now."

  • 12 replies
  • 21 have this problem
  • 1861 views
  • Last reply by jscher2000

more options

Every time I go into my Yahoo mail the above message pops up. I really don't like Yahoo search. How do I get this message to stop popping up? Ever since it started popping up Yahoo mail is glitchy and slow (only on the 2 computers with Firefox). I'd like to keep Firefox, but will switch if this isn't fixable.

Chosen solution

I wonder whether you have the Yahoo Toolbar or some other add-on that is promoting Yahoo search. I ask because even when I open Yahoo in a private window to bypass any existing cookies, I don't see that message. (But admittedly, I am blocking some of the ad servers used by Yahoo.)

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

Read this answer in context 👍 2

All Replies (12)

more options

Is there not an X there to dismiss the message? If so, click it and it should place a cookie in Firefox telling Yahoo you don't want to see that message

Please note, this is a message from Yahoo, not Firefox.

more options

There is an "X", which I click on every time I open my mail, but since it began appearing the whole page freezes up. I'm hoping there's a way to keep Firefox and lose that message for good.

more options

Chosen Solution

I wonder whether you have the Yahoo Toolbar or some other add-on that is promoting Yahoo search. I ask because even when I open Yahoo in a private window to bypass any existing cookies, I don't see that message. (But admittedly, I am blocking some of the ad servers used by Yahoo.)

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

Also make sure that you enable localStorage as such a choice might possibly be saved there.

You can check if DOM Storage is enabled.

more options

DianaAtTheBeach said

Every time I go into my Yahoo mail the above message pops up. I really don't like Yahoo search. How do I get this message to stop popping up? Ever since it started popping up Yahoo mail is glitchy and slow (only on the 2 computers with Firefox). I'd like to keep Firefox, but will switch if this isn't fixable.

me too firefox 38.0.5 mac mini 10.10.3 - i have no yahoo extensions or addons. this just started about 8 days ago. i clicked "Not Now" there is no "Not Ever" and there is a Sponsored Ad to change to Firefox. some kind of corporate collusion going on here! soon we'll be getting Ads "TPP is good for you" and "NSA Spying on every American is good for you".

more options

Hi AlienLanes, what extensions do you have? You can copy/paste a list from the support information page. Open that using either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

Extensions is the third or fourth table down the page. It might look a little messy when pasted, but that's okay.

more options

Try to toggle the browser.search.geoSpecificDefaults pref to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

jscher2000 said

Hi AlienLanes, what extensions do you have? You can copy/paste a list from the support information page. Open that using either:
  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return
Extensions is the third or fourth table down the page. It might look a little messy when pasted, but that's okay.

Extensions DuckDuckGo Plus 0.4.6.1-signed true jid1-ZAdIEUB7XOzOJw@jetpack Firebug 2.0.10 true firebug@software.joehewitt.com Ghostery 5.4.5.1-signed true firefox@ghostery.com IRC Client 0.3.1.1-signed true jid0-K46oZsrmaZZ4545Aueo0NXxk0c4@jetpack Adobe Acrobat - Create PDF 1.1 false web2pdfextension@web2pdf.adobedotcom Charles Autoconfiguration 3.10.1 false {3e9a3920-1b27-11da-8cd6-0800200c9a66}

thanks j,

i've never been in this area of FF browser. wow, it sure has a lot of components. if you don't use Ghostery, it's a fantastic blocker!

more options

cor-el said

Try to toggle the browser.search.geoSpecificDefaults pref to false on the about:config page. You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

LOL cor el, THANKS! just the places i want to be, were the government and corporations warn me not to be! and very few corporations honor warranties now-a-days, they find some fine print to claim "we've" voided their terms.

is there a help area that explains the meanings of these preferences and values?

thank you!

more options

Hi AlienLanes, thank you for the extension list, none of the enabled ones look suspicious to me. Most of the information on the about:support page is for internal reference only and not available to websites.

I could not find a way to trigger that bar to display (removed all cookies, for example), but with so many customizations accumulated over the years, perhaps it is blocked somehow on my Firefox. I may need to test in a clean new profile.

Also, Yahoo also uses a number of different servers for mail, so mine (us-mg4.mail.yahoo.com) might simply not be running that campaign, which would make it even harder to investigate...

more options

DianaAtTheBeach said

Every time I go into my Yahoo mail the above message pops up. I really don't like Yahoo search. How do I get this message to stop popping up? Ever since it started popping up Yahoo mail is glitchy and slow (only on the 2 computers with Firefox). I'd like to keep Firefox, but will switch if this isn't fixable.

This is the one that did it, thanks! Yahoo kept freezing the page so I had a heck of a time reading the answers, finally got to this one. (I tried signing in to read the answers in the post, but couldn't find the thread.) Thanks again!

more options

Hi DianaAtTheBeach, I think you were referring to the problem not occuring in Firefox's Safe Mode. Sometimes when you exit out of Safe Mode and start Firefox up normally again, things are magically fixed, but in other cases, the problems return.

The Safe Mode test covers many things at once, so I'm not 100% sure which is helping you, but you could consider reviewing your extension list and considering whether any are nonessential and could be disabled for a day or two to test whether that resolves the annoying message on Yahoo.

Because Safe Mode automaticaly disables extensions, you might not be able to do this until exiting Firefox and starting up again normally.

Open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.