X
Tap here to go to the mobile version of the site.

Support Forum

Inbox by Gmail fails to display after extended time open

Posted

I'm using the new Inbox by Gmail and after an hour or two open it consistently fails to display properly and can only be corrected via restart. Scrolling up or down cause choppy display issues, and if left for longer it eventually just displays a black screen. Refreshing does not help nor does closing the tab and reopening. This happens every time the tab is open.

I'm using the new Inbox by Gmail and after an hour or two open it consistently fails to display properly and can only be corrected via restart. Scrolling up or down cause choppy display issues, and if left for longer it eventually just displays a black screen. Refreshing does not help nor does closing the tab and reopening. This happens every time the tab is open.

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.9
  • Citrix Online App Detector Plugin
  • Citrix Receiver Plugin (Win32)
  • Citrix URL-Redirection Helper Plugin
  • Gaaiho Doc Plugin
  • IE Tab plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.79.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • np-mswmp
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

guigs 1072 solutions 11697 answers

Helpful Reply

Please update to the most recent version of Firefox:

Please update to the most recent version of Firefox: *[[Update Firefox to the latest version]]
guigs 1072 solutions 11697 answers

Also I took a look at it again, do you have any themes or extensions, it is possible to make sure that hardware acceleration or add ons are not affecting the page. Try Firefox Safe Mode:

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Also I took a look at it again, do you have any themes or extensions, it is possible to make sure that hardware acceleration or add ons are not affecting the page. Try Firefox Safe Mode: '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Question owner

So I updated to 38.0.1 and have tried the extension troubleshooting. I do have many extensions. 16 that I count when I check under Add-Ons and 18 listed in Firefox Health Report. In Safe Mode the behavior seemed to go away. I've disabled hardware acceleration and disabled all extensions except three that I consider essential for day-to-day work. (Lastpass, Xmarks, and Hootsuite.) It's definitely a noticeable improvement, but if I have 6-8 tabs open, do some searching on Google Maps, and scroll down a ways in my twitter feeds through Hootsuite I start to see the display problems on Inbox again. It's far more usable, but still not ideal, and I worry it will get worse the longer the browser is open. I'm no expert, but seems like a memory leak issue right?

So I updated to 38.0.1 and have tried the extension troubleshooting. I do have many extensions. 16 that I count when I check under Add-Ons and 18 listed in Firefox Health Report. In Safe Mode the behavior seemed to go away. I've disabled hardware acceleration and disabled all extensions except three that I consider essential for day-to-day work. (Lastpass, Xmarks, and Hootsuite.) It's definitely a noticeable improvement, but if I have 6-8 tabs open, do some searching on Google Maps, and scroll down a ways in my twitter feeds through Hootsuite I start to see the display problems on Inbox again. It's far more usable, but still not ideal, and I worry it will get worse the longer the browser is open. I'm no expert, but seems like a memory leak issue right?

Question owner

Just tried it with the last 3 extensions disabled and still eventually wound up with the same issue. Again some improvement, but not really a fix.

Just tried it with the last 3 extensions disabled and still eventually wound up with the same issue. Again some improvement, but not really a fix.
guigs 1072 solutions 11697 answers

This could also mean hardware acceleration.

This could also mean hardware acceleration. *Please make sure that the drivers are up to date: [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

Did you check the memory usage of Firefox when this happens?

You can also check the about:memory page.


Try to create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Did you check the memory usage of Firefox when this happens? You can also check the about:memory page. ---- Try to create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

@Guigs2 making sure drivers were updated required a work ticket and therefore took quite a while. However it is now done and the drivers were all latest version.

@cor-el task manager shows Firefox taking up 1GB of memory. On a clean start (with 6 pinned tabs open) it starts at 592Mb, and then gradually creeps upward. At one point I tracked when the display issues started, I think it was around 800Mb but can't quite remember.

I could deal with this if I could reduce the memory usage by closing tabs, but that fails to free up memory and the display problems reappear.

@Guigs2 making sure drivers were updated required a work ticket and therefore took quite a while. However it is now done and the drivers were all latest version. @cor-el task manager shows Firefox taking up 1GB of memory. On a clean start (with 6 pinned tabs open) it starts at 592Mb, and then gradually creeps upward. At one point I tracked when the display issues started, I think it was around 800Mb but can't quite remember. I could deal with this if I could reduce the memory usage by closing tabs, but that fails to free up memory and the display problems reappear.

Question owner

This looks very familiar: https://support.mozilla.org/en-US/questions/1011071. I used to get similar crashes, and while the crashing has largely disappeared, it has been replaced with Inbox by Gmail becoming largely unusable and requiring restart.

This looks very familiar: https://support.mozilla.org/en-US/questions/1011071. I used to get similar crashes, and while the crashing has largely disappeared, it has been replaced with Inbox by Gmail becoming largely unusable and requiring restart.

Question owner

So I tried Enabling Hardware Acceleration and the display issues with Inbox largely went away. However, other tabs started having issues (e.g. Twitter) and then I had my first crash in months. Is it possible to enable hardware acceleration for a single page or is it all or nothing?

So I tried Enabling Hardware Acceleration and the display issues with Inbox largely went away. However, other tabs started having issues (e.g. Twitter) and then I had my first crash in months. Is it possible to enable hardware acceleration for a single page or is it all or nothing?

Question owner

Pains me to say it since I've been a Firefox user for years, but this is going to prompt me to switch to Chrome. I just checked and several extensions that I use which were previously Firefox only are now available on Chrome, and it seems much better in terms of the display problems after being open for some time. Hope a solution presents itself eventually.

Pains me to say it since I've been a Firefox user for years, but this is going to prompt me to switch to Chrome. I just checked and several extensions that I use which were previously Firefox only are now available on Chrome, and it seems much better in terms of the display problems after being open for some time. Hope a solution presents itself eventually.
guigs 1072 solutions 11697 answers

HI cmcnally, Thank you for the responses, it sounds like you are looking for a solution for turning off or on hardware acceleration for certain tabs. Currently this is not something that I have explored. However if you have the crash reports, it may reveal some more information: We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste those IDs into the "Post a Reply" box.

Note: If a recent Report ID does not start with bp- click on it to submit the report.

(Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.)

aboutcrashesFx29

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

HI cmcnally, Thank you for the responses, it sounds like you are looking for a solution for turning off or on hardware acceleration for certain tabs. Currently this is not something that I have explored. However if you have the crash reports, it may reveal some more information: We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash. #Enter ''about:crashes'' in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below. #Copy the '''5''' most recent Report IDs that start with '''bp-''' and then go back to your forum question and paste those IDs into the "Post a Reply" box. ''' Note:''' If a recent Report ID does not start with '''bp-''' click on it to submit the report. (Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.) ;[[Image:aboutcrashesFx29|width=500]] Thank you for your help! More information and further troubleshooting steps can be found in the [[Firefox crashes - Troubleshoot, prevent and get help fixing crashes]] article.