X
Tap here to go to the mobile version of the site.

Support Forum

Text is too light on web pages.

Posted

I have Windows 7 and Firefox 32.0.3. I often come across web pages on which the text is such light gray that it's impossible to read. In a previous thread about this, the instructions were: "go into the windows control panel & reconfigure cleartype settings: http://windows.microsoft.com/en-US/windows7/make-text-easier-to-read-using-cleartype"

It worked for someone, but it did nothing for me. How can I make the text on web pages dark enough to read?

I have Windows 7 and Firefox 32.0.3. I often come across web pages on which the text is such light gray that it's impossible to read. In a previous thread about this, the instructions were: "go into the windows control panel & reconfigure cleartype settings: http://windows.microsoft.com/en-US/windows7/make-text-easier-to-read-using-cleartype" It worked for someone, but it did nothing for me. How can I make the text on web pages dark enough to read?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.12
  • Next Generation Java Plug-in 10.67.2 for Mozilla browsers
  • 5.1.30514.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.9.149
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.9
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

More Information

guigs 1072 solutions 11697 answers

Helpful Reply

Hi shanter, Thank you for your question, I understand that there are still some pages that have grey text and hard to read even after trying cleartype.

The other option built into the browser that you can change the default text color is in this menu: Options > Content > Fonts and colors

Here you can choose for websites to choose the font or can choose the default font color.

However if this does not help, can you please provide an example website where this is happening for further investigation.

Thanks.

Hi shanter, Thank you for your question, I understand that there are still some pages that have grey text and hard to read even after trying cleartype. The other option built into the browser that you can change the default text color is in this menu: Options > Content > Fonts and colors Here you can choose for websites to choose the font or can choose the default font color. However if this does not help, can you please provide an example website where this is happening for further investigation. Thanks.
cor-el
  • Top 10 Contributor
  • Moderator
17690 solutions 160039 answers

Helpful Reply

ClearType only makes the font looking better. It doesn't affect the text color in case web pages specify such a faint color like this forum does.

You can use the NoSquint extension to set font size (text/page zoom) and text color on web pages.

It is also possible to do this with with code in Stylish or userContent.css for websites that you visit frequently. I usually try a bookmarklet in cases like this to improve the readability.

javascript:(function(){var SS=document.createElement('style');SS.setAttribute('type','text/css');SS.id='style_bbw';SS.innerHTML='*{color:#222!important;background-color:#f8f8f8} a{text-decoration:underline!important}a[href] *{color:#25f!important}a[href^="javascript:"],a[onclick]{cursor:move;color:green!important}';document.querySelector('head').appendChild(SS);})()
ClearType only makes the font looking better. It doesn't affect the text color in case web pages specify such a faint color like this forum does. You can use the NoSquint extension to set font size (text/page zoom) and text color on web pages. *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/ It is also possible to do this with with code in Stylish or userContent.css for websites that you visit frequently. I usually try a bookmarklet in cases like this to improve the readability. <pre><nowiki>javascript:(function(){var SS=document.createElement('style');SS.setAttribute('type','text/css');SS.id='style_bbw';SS.innerHTML='*{color:#222!important;background-color:#f8f8f8} a{text-decoration:underline!important}a[href] *{color:#25f!important}a[href^="javascript:"],a[onclick]{cursor:move;color:green!important}';document.querySelector('head').appendChild(SS);})() </nowiki></pre>
finitarry 251 solutions 3421 answers

I have some bookmarklets that can retheme a page if the text is hard to read. That is what I do to fix that problem. This is a page with such bookmarklets:

I have some bookmarklets that can retheme a page if the text is hard to read. That is what I do to fix that problem. This is a page with such bookmarklets: * http://great-grandma.com/bookmarklet/darken-rev_zzr.html

Question owner

Thank you! By going to Tools/Options/Content/Fonts & Colors/Colors and unchecking the box by "Allow pages to choose their own colors, instead of my selections above" (and My selections are white background, black text), IT WORKED!

My getting-older eyes thank you, too. :-)

Thank you! By going to Tools/Options/Content/Fonts & Colors/Colors and unchecking the box by "Allow pages to choose their own colors, instead of my selections above" (and My selections are white background, black text), IT WORKED! My getting-older eyes thank you, too. :-)
cor-el
  • Top 10 Contributor
  • Moderator
17690 solutions 160039 answers

Note that you disable background images that way, so you may be getting problems with page elements (buttons) that solely consist of a background image.

A better option is usually to use the above mentioned NoSquint extension.

Note that you disable background images that way, so you may be getting problems with page elements (buttons) that solely consist of a background image. *http://kb.mozillazine.org/Website_colors_are_wrong A better option is usually to use the above mentioned NoSquint extension.