Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Javascrpt i

  • 2 Antworten
  • 0 haben dieses Problem
  • 21 Aufrufe
  • Letzte Antwort von cor-el

more options

Hi - I installed a fresh copy of Firefox. However, when I click on a desktop icon to start a program, I get an error message to "Enable Javascript". I checked the registry, and sure enough, "Enable Javascript" is set to "True". I disabled some extensions that I thought might be causing the problem, but that didn't fix the problem. Anyone out there who had this problem, and fixed it, kindly share your solution with me. Thank you, Nick M.

Hi - I installed a fresh copy of Firefox. However, when I click on a desktop icon to start a program, I get an error message to "Enable Javascript". I checked the registry, and sure enough, "Enable Javascript" is set to "True". I disabled some extensions that I thought might be causing the problem, but that didn't fix the problem. Anyone out there who had this problem, and fixed it, kindly share your solution with me. Thank you, Nick M.

Alle Antworten (2)

more options

Hi Nick M,

I understand that you're experiencing an issue with enabling JavaScript in Firefox after installing a fresh copy. I'm here to assist you with finding a solution.

To troubleshoot this problem, I recommend trying the following steps:

Clear the Firefox cache: Go to the menu (three horizontal lines) in the top-right corner of the browser window, select "Options," then go to the "Privacy & Security" tab. Scroll down to the "Cookies and Site Data" section and click on the "Clear Data" button. Make sure to check the box for "Cached Web Content" and click "Clear."

Check the JavaScript settings: In the Firefox address bar, type "about:config" (without quotes) and press Enter. You will see a warning message, but you can proceed by clicking the "Accept the Risk and Continue" button. In the search bar at the top, type "javascript.enabled" and make sure the value is set to "true." If it's set to "false," double-click on it to change it to "true."

Disable hardware acceleration: Sometimes, hardware acceleration can cause conflicts with certain programs. To disable it, go to the menu, select "Options," then go to the "General" tab. Scroll down to the "Performance" section and uncheck the box for "Use recommended performance settings." Then, uncheck the box for "Use hardware acceleration when available."

Reset Firefox settings: If the above steps didn't resolve the issue, you can try resetting Firefox to its default settings. To do this, go to the menu, select "Help," then choose "Troubleshooting Information." In the new tab that opens, click on the "Refresh Firefox" button.

Please let me know if any of these steps help resolve the issue. If not, I'll be happy to assist you further.

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window