Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

after booting opensuse leap 15.4 firefox displays splashscreen instead of web pages

  • 13 Antworten
  • 0 haben dieses Problem
  • 4 Aufrufe
  • Letzte Antwort von Erik

more options

I have this ennoying issue since some months and didn't find a way of fixing it, even by completely deleting the app and removing all remnants of profiles before re-installing it. If I leave Firefox open when I shut down my computer, most of the time (but not every time!) instead of opening the last window with its tabs, Firefox displays the KDE Plasma's or OpenSuse's splash screen (which is a lamp bulb on a black background) and no menu). If I minimize the window, and maximize it again, it displays a screenshot of my desktop!... I can't do anything but close the window and re-launch firefox, but then the history of last closed windows is gone.

I have the same version of FF and the same version of OpenSuse on two other computers and never had this issue on them.

I would be grateful to anybody who could give me some tips to solve it or even investigate!

Thanks for reading. Erik

I have this ennoying issue since some months and didn't find a way of fixing it, even by completely deleting the app and removing all remnants of profiles before re-installing it. If I leave Firefox open when I shut down my computer, most of the time (but not every time!) instead of opening the last window with its tabs, Firefox displays the KDE Plasma's or OpenSuse's splash screen (which is a lamp bulb on a black background) and no menu). If I minimize the window, and maximize it again, it displays a screenshot of my desktop!... I can't do anything but close the window and re-launch firefox, but then the history of last closed windows is gone. I have the same version of FF and the same version of OpenSuse on two other computers and never had this issue on them. I would be grateful to anybody who could give me some tips to solve it or even investigate! Thanks for reading. Erik
Angefügte Screenshots

Alle Antworten (13)

more options

Do you have the same issue with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

Put Firefox in Safe Mode and repeat the same steps.

Geändert am von jonzn4SUSE

more options

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

more options

Also, are your graphic drivers current? If you're running nvidia, have you ever tried this site? --> https://www.opensuse-community.org/ Are you in Wayland or X11? Post your system info...


Operating System: openSUSE Tumbleweed 20230208 KDE Plasma Version: 5.26.5 KDE Frameworks Version: 5.102.0 Qt Version: 5.15.8 Kernel Version: 6.1.10-1-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 5825U with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Manufacturer: HP Product Name: HP ProBook 455 15.6 inch G9 Notebook PC

Geändert am von jonzn4SUSE

more options

Thanks everybody for your replies !

@jonzn4SUSE : unfortunately if I can put Firefox in safe mode, it does not remain in this state after re-booting, so I am unable to repeat the same steps - or maybe am I missing something ? My OS is up to date (for Leap 15.4 of course, maybe not so up to date as for Tumbleweed ?) and the behavior was the same with the previous graphics which were integrated to Intel CPU - now it is an AMD Radeon RX 570 (...). Most of the time I only rely on drivers provided by openSUSE, and it was installed after pluging the graphic card in. Would you give a different advice ?

@cor-el : I'll try that this weekend.

For info I posted on suse forums too, and had a reply about a possible graphic acceleration problem, preventing compositor from painting the firefox window properly. It's a bit far beyond my ability but could be related to drivers too. I'm a bit confused about this question of drivers, because if it were the cause, why does the problem remain with a new graphic card ?

more options

Wayland or X11? What do you have set here? see screenshot

Geändert am von jonzn4SUSE

more options

@jonznSUSE : Hi!

my answers :

  • X11
  • same settings as on your screenshot.

Have a good sunday!

more options

cor-el said

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

Did you try this? I stopped running the distro version as my daily driver a few years ago because of session issues. It's a good idea to have multiple versions in case 1 goes BOOM.

more options

So you mean both version can be installed on the same machine ? (Probably not running simultaneously though ?)

more options

On Linux, it is easy to install multiple Firefox versions from the Mozilla server as there is no installer, you merely have download and save the installer file and extract the files in the tar.mbz2 archive to the folder where you want to install it. The distro version can only be installed once.

more options

When launching downloaded version of Firefox from tty, I have the error message : "[GFX1-]: glxtest: VA-API test failed: failed to initialise VAAPI connection.". From what I read on the web, it can cause various problems and should require disabling hardware acceleration.

more options

No, just download and run firefox-bin from the folder, I just created links on my desktop. Only distro version is installed and the others are running from my downloads folder.

more options

See also:

more options

This Firefox version does not crash, it just displays this message about VA-API, but downgrading mesa seems to be a good thing to try. I am currently trying various tips on the OS version, like clearing the cache, I'll see a bit later if the non-OS version works better with this workaround. Thanks !

Geändert am von Erik