Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable new URL bar in Version 75

  • 62 Antworten
  • 25 haben dieses Problem
  • 10340 Aufrufe
  • Letzte Antwort von Kiki

more options

Hello all,

this new expanding URL Bar is HORRIBLE. How can i disable this stupid implementation ?

Thanks for your help.

Geändert am von Airdropper

Ausgewählte Lösung

Hello Airdropper,

I totally agree with you ....

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

(if it's only the Top Sites suggestions that you want to get rid of : setting the value of first preference to "false" will do that)

Diese Antwort im Kontext lesen 👍 11

Alle Antworten (20)

more options

I didn't want address-bar search 7 years ago and I don't want it now! https://support.mozilla.org/en-US/questions/944243

more options

jscher2000:

Thanks for all the help. The theme author, MaDonna, seems to have done something in her themes because some of them have a black background on the search dropdown while others are white. Most other themes by other authors are white. But, your combined recommendations are satisfactory. Not sure where I can find the CSS language you used but thanks very much.

more options

Ed Randall said

I didn't want address-bar search 7 years ago and I don't want it now! https://support.mozilla.org/en-US/questions/944243

Luckily for you, that preference hasn't changed. (keyword.enabled => false)

But I assume you posted this comment for some other reason not related to searching?

more options

I am hating this new jumbo URL idea. I would like to know who the idiot was who came up with this idea. Please step forward for the public shaming you so richly deserve.

I tried the advice here to stop it but it had no effect. Im so tired of FF that I am really really ready to call it quits.

I remember the days when you could make telephone calls using email addresses with netscape. anyone else?

more options

pixelpadre said

I am hating this new jumbo URL idea. ... I tried the advice here to stop it but it had no effect.

The original solution was for Firefox 75-76 which had the "update1" opt-out preference. That is gone in Firefox 77.

You can use an optional userChrome.css file to prevent the enlargement of the address bar box. It's a little bit involved, so please set aside 10 quiet minutes to work through it.

(For anyone who already has a userChrome.css file set up, you just need to add the rules you downloaded under (A) to your file.)

(A) Download a rules file

https://www.userchrome.org/samples/userChrome-ZeroEnlargement.css

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See attached screenshot)

Minimize that file browser window for later reference.

(B) Create a new chrome folder in your currently active profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(C) Move the userChrome-ZeroEnlargement.css file you downloaded in Step A into the chrome folder you created in Step B

(D) If you do not already have a userChrome.css file, Rename the userChrome-ZeroEnlargement.css file

Right-click userChrome-ZeroEnlargement.css and choose Rename. Carefully remove -ZeroEnlargement and press Enter to save your change. The final file name needs to be userChrome.css or Firefox will never find it.

(E) Set Firefox to look for userChrome.css at startup -- see step #6 in the above article.

The next time you exit Firefox and start it up again, it should discover that file and apply the rules.

Success?

more options

I have already read that nonsense work around. If you said save 10 minutes that means 5 minutes. Not doing it. What is it with FF that they can't get their shit together? FF is becoming THE number 1 garbage browser on the internet because they will not listen. 77 releases and they still cant get it right. Nuff said.

Geändert am von pixelpadre

more options

Hi pixelpadre, as know from reading the rest of the thread, support forum volunteers aren't the programmers or UI designers. Maybe I can help you implement this community-developed workaround if you want to "fix" the bar today, but if you just wanted to vent, then I think we're done.

more options

I don't mind the suggestions too much, though I have never used them, but the way that the whole URL changes to blue rather than allowing me to select and (in-negative) highligh part of the URL is annoying.

Please would someone be so kind as to tell me which of the about config settings or CSS allows me to return to a standard text selection highlight behaviour in the URL bar?

more options

Hi Timtak, I'm not sure whether you are having problems with selection colors or the fact that text is automatically selected.

The current text is automatically selected when focus moves into the bar, and I don't think there is an off switch for that (I realize Linux worked differently before).

Highlight Colors in the Address Bar

I think this only affects some add-on themes, due to changes in the way Mozilla requires theme authors to assign colors. You shouldn't notice any problem with the built-in themes (Default, Light, Dark).

If you need to override the selection colors for an add-on theme, you can use custom style rules. If you are using an approach like the one described earlier in answer-1324907 then you can add these additional rules to use Firefox's default colors for your OS (commonly white on blue):

#urlbar {
  --lwt-toolbar-field-highlight: Highlight;
  --lwt-toolbar-field-highlight-text: HighlightText;
} 
more options

jscher2000 said

Success?

Yes! Thank you! When I click on the URL bar, before I start typing, my top sites are suggested - how can I get rid of them?

more options

guest007 said

jscher2000 said

Success?

Yes! Thank you! When I click on the URL bar, before I start typing, my top sites are suggested - how can I get rid of them?

To prevent the list opening automatically in Firefox 75-77:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.openViewOnFocus preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

In Firefox 78+, there's going to be a checkbox on the Options/Preferences page > Privacy & Security > Address Bar section:

more options

McCoy said

Hello Airdropper, I totally agree with you .... Would you do this please : Type in the address bar about:config and press Enter. (ignore the warning) Type in the search bar and look for the preference : browser.urlbar.openViewOnFocus and set its value to false Do the same with these preferences : browser.urlbar.update1 browser.urlbar.update1.interventions browser.urlbar.update1.searchTips Then close and restart Firefox. (if it's only the Top Sites suggestions that you want to get rid of : setting the value of first preference to "false" will do that)

Doesn't work

more options

jscher2000 said

guest007 said

jscher2000 said

Success?

Yes! Thank you! When I click on the URL bar, before I start typing, my top sites are suggested - how can I get rid of them?

To prevent the list opening automatically in Firefox 75-77:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.openViewOnFocus preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

In Firefox 78+, there's going to be a checkbox on the Options/Preferences page > Privacy & Security > Address Bar section:

browser.urlbar.openViewOnFocus is not found in about:config

more options

pixelpadre said

I have already read that nonsense work around. If you said save 10 minutes that means 5 minutes. Not doing it. What is it with FF that they can't get their shit together? FF is becoming THE number 1 garbage browser on the internet because they will not listen. 77 releases and they still cant get it right. Nuff said.

Agreed, I'm just about done with Firefox at this point! Infuriating that they make these changes WITHOUT allowing people to customize things back to what they were.

more options

@ Airdropper :

It's when I wanted to go over this thread again, that I noticed that you had just edited your original post.

What you probably don't know :   when you edit a post, nobody will receive an email notification, and chances that anyone will see what you have changed are very slim.

It's always best to write an new post, to make sure it will get people's attention.

more options

In current releases you can create a new Number pref on the about:config page named ui.prefersReducedMotion and set the value to 1 if you want to block animations or set its value to 0 if you want to see animations.

  • ui.prefersReducedMotion = 1

See also:

more options

jscher2000 said

Hi Timtak, I'm not sure whether you are having problems with selection colors or the fact that text is automatically selected. The current text is automatically selected when focus moves into the bar, and I don't think there is an off switch for that (I realize Linux worked differently before). Highlight Colors in the Address Bar I think this only affects some add-on themes, due to changes in the way Mozilla requires theme authors to assign colors. You shouldn't notice any problem with the built-in themes (Default, Light, Dark). If you need to override the selection colors for an add-on theme, you can use custom style rules. If you are using an approach like the one described earlier in answer-1324907 then you can add these additional rules to use Firefox's default colors for your OS (commonly white on blue):
#urlbar {
  --lwt-toolbar-field-highlight: Highlight;
  --lwt-toolbar-field-highlight-text: HighlightText;
} 

Thank you very much indeed. I am sorry I missed your post.

But alas now answer-1324907 seems to have been removed, and adding

#urlbar {
  --lwt-toolbar-field-highlight: Highlight;
  --lwt-toolbar-field-highlight-text: HighlightText;
} 

to userchrome.css (which I am using to get multirow tabs) does not seem to change the way that the URL bar is highlighted. I am not sure if automatic selection is a problem or not, but I do not like the light blue on white highlighting at all. I wish it would behave like an other text such as the text that I am typing but going back to negative (white on dark blue) would help a lot.

more options

Hi Timtak, I don't know what happened to that answer link, but it just went to this reply further up the page:

https://support.mozilla.org/en-US/questions/1283831?page=3#answer-1324907

The incorrect highlighting seems to be an issue with some add-on themes, possibly caused by changes in how Firefox wants theme authors to refer to different colors. Anyway, in order to experiment, it would be useful to know which theme are you using.

more options

Thank you. I added the css https://www.userchrome.org/samples/userChrome-ZeroEnlargement.css and the css that you suggested, but I see no change in my url bar, alas.

Perhaps this is because of some incompatibility with the user chrome css that I am already ussing, or for some other reason.

It is kind of you to try.

more options

I also tried adding the suggested css before the css that I have (to enable multi-row tabs) and that did not have any effect on the URL bar either, though, fortunately I still have multi-row tabs.

  1. 1
  2. 2
  3. 3
  4. 4