Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Amazon Parent Dashboard not functioning on Firefox (but works on Chrome)

more options

Anyone else had the problem of not being able to sign in to the Amazon Parent Dashboard via Firefox? But works on Chrome. Same on desktop and android versions of Firefox.

Amazon chat support not helpful and just told me to use Chrome!

Anyone else had the problem of not being able to sign in to the Amazon Parent Dashboard via Firefox? But works on Chrome. Same on desktop and android versions of Firefox. Amazon chat support not helpful and just told me to use Chrome!

Valgt løsning

benshakespeare said

via a private browsing window, it will log in.

Try disabling your extensions, they usually don't run in private tabs unless explicitly allowed.

When it tries to open in a normal window it runs through the app briefly

You can avoid this by going to Settings > Open links in apps > Never.

Læs dette svar i sammenhæng 👍 1

Alle svar (4)

more options

Try clearing site cookies and disabling Tracking Protection for the site.

Does it still happen in Troubleshoot Mode?

Nyttig?

more options

The site now works on Firefox desktop but not Android. I have tracked it down to something related to the Amazon App when working alongside Firefox. When I force a login to https://www.amazon.co.uk/parents/ via a private browsing window, it will log in. When it tries to open in a normal window it runs through the app briefly before going back to Firefox. When this happens, it will not load.

When I set Chrome as my default browser on Android, it all works.

I could not see a way of putting Firefox Android into a Safe/Troubleshoot mode.

Anyone with any ideas?

Nyttig?

more options

Valgt løsning

benshakespeare said

via a private browsing window, it will log in.

Try disabling your extensions, they usually don't run in private tabs unless explicitly allowed.

When it tries to open in a normal window it runs through the app briefly

You can avoid this by going to Settings > Open links in apps > Never.

Nyttig?

more options

I don't have any extensions but this worked: You can avoid this by going to Settings > Open links in apps > Never.

Thanks for your help!

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.