Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Latest version No Playing Sounds

  • 8 svar
  • 2 har dette problem
  • 24 visninger
  • Seneste svar af AMTebg

more options

Firefox is not playing sound in youtube videos. I have tried all the solutions I cna find on line. To be clear it is only firefox that is not playing sounds other browsers play sound and other apps play sound.

The firefox tab is not muted The mixer shows full volume on firefox tabs My speakers work and the mixer is defualting to the speakers None of my audio devices show any issues at all Youtube videos play in FF but just with no sound and no the sound is not muted in any way I can see I have tried uninstalling and resinstalling FF I have tried turn of acceleration

I am now at a loss I hvae nvida graphics card which I thiink has uptodate drivers

Any suggestions

Firefox is not playing sound in youtube videos. I have tried all the solutions I cna find on line. To be clear it is only firefox that is not playing sounds other browsers play sound and other apps play sound. The firefox tab is not muted The mixer shows full volume on firefox tabs My speakers work and the mixer is defualting to the speakers None of my audio devices show any issues at all Youtube videos play in FF but just with no sound and no the sound is not muted in any way I can see I have tried uninstalling and resinstalling FF I have tried turn of acceleration I am now at a loss I hvae nvida graphics card which I thiink has uptodate drivers Any suggestions

Alle svar (8)

more options

Links to the problem video so others can see if this is a browser or hardware or software driver issue?

more options

Hello AMTebg,

Apologies if this is a rethorical question, but : do you see a special icon on the address bar, as described in this article :

https://support.mozilla.org/en-US/kb/block-autoplay  ?

If that's not it, maybe you start Firefox in Safe Mode to see if maybe one of your extensions is the culprit :

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Also see :

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

more options

THANKS FOR YOUR REPLIES i AHVE TRIED ALL OF THESE SUGGESTION AND NOTHING WORKS IT DOES NOT EVEN WORK IN SAFE MODE WITH NO PLUGINS.

IT IS ON ALL VIDEOS IN MOZILLA I DO NOT HAVE THE SAME PROBLEM IN OPERA OR EDGE ON THE SAME MACHINE

more options

In your original post you mention that you've tried every solution you could find - do they include checking preferences on the "about:config" page ?

If not : type in the address bar about:config and press Enter

Type in the search bar media.autoplay and check the values of these preferences :

media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]

media.autoplay.allow-muted = false

media.autoplay.enabled.user-gestures-needed :

You'll have to experiment with the value, to see whether false or true works for you.

Also try to toggle :

media.block-autoplay-until-in-foreground

After you've made changes, close and restart Firefox.

more options

Thanks for the suggestion I have tried all of these and still no joy?

more options

AMTebg said

IT DOES NOT EVEN WORK IN SAFE MODE WITH NO PLUGINS.

Bummer ..... there are two extensions (not plugins) listed in your system details, that looked "suspicious" to me, in the sense that I was hoping that one of them might be the culprit.

You have tried everything in the book to no avail and I've run out of ideas.

I'm hoping that someone else will come to your rescue .....

more options

You can check the Web Console for media related messages

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

in webconsole i am getting this error message on the youtube site Failed to register/update a ServiceWorker for scope ‘https://www.youtube.com/’: Storage access is restricted in this context due to user settings or private browsing mode.