Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

All sites on Firefox take over 5 minutes to load.

  • 1 svar
  • 1 har dette problem
  • 30 visninger
  • Seneste svar af Shadow110

more options

Hi. I've been a long time Firefox user. Within the last week, it now takes at least 5 minutes for any site, i.e. YouTube, Twitter, Instagram, etc. to load. I've tried all of the suggestions recommended, including refreshing Firefox and going back to original settings. Nothing is working. Sometimes, even after a site, i.e. YouTube finally loads, the video will start buffering after it loads. Google chrome seems to be working fine so I've had to start using that instead. I really like Firefox best so I hope there can be a resolution.

Hi. I've been a long time Firefox user. Within the last week, it now takes at least 5 minutes for any site, i.e. YouTube, Twitter, Instagram, etc. to load. I've tried all of the suggestions recommended, including refreshing Firefox and going back to original settings. Nothing is working. Sometimes, even after a site, i.e. YouTube finally loads, the video will start buffering after it loads. Google chrome seems to be working fine so I've had to start using that instead. I really like Firefox best so I hope there can be a resolution.

Alle svar (1)

more options

Hi, sorry having issues let's try a few things.

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

If this is a older system with low ram but running Win 10 might want to switch to the Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

If everything checks out and not moving please give this a try : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.