Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Suddenly the backgrounds to many Firefox screens - browser, history, settings - changed from white to black. This makes it very difficult for me to read whats on these screens. How do I change them back to white?

  • 10 replies
  • 5 have this problem
  • 167 views
  • Last reply by FredMcD

more options

Suddenly the backgrounds to many Firefox screens - browser, history, settings - changed from white to black. This makes it very difficult for me to read whats on these screens. How do I change them back to white?

The browser screen was black and I did that "about:config" thing and toggled the "browser.proton.enabled" to False which converted the background of the browser to back to white but all the other drop down menus are still black. The bookmark toolbar menu is black, the background of the hamburger menu is black, and the "customize menu" background is black. These areas are now difficult for me to see.

When FF developers start fooling around with colors in the FF browser they need to tread lightly and be aware of all accessibility problems their users may have. Where accessibility is concerned, one size doesn't fit all. Some people have problems with white backgrounds and others, like myself, have problems reading screens with black backgrounds. One simply MUST be aware of sight problems in users.

P.S. I tried uploading photos of the black backgrounds in question but the upload wheel just kept spinning. The photo size was within accepted parameter. Also, I tried to check the box "Email me when someone answers the thread" but that wouldnt work either.

Suddenly the backgrounds to many Firefox screens - browser, history, settings - changed from white to black. This makes it very difficult for me to read whats on these screens. How do I change them back to white? The browser screen was black and I did that "about:config" thing and toggled the "browser.proton.enabled" to False which converted the background of the browser to back to white but all the other drop down menus are still black. The bookmark toolbar menu is black, the background of the hamburger menu is black, and the "customize menu" background is black. These areas are now difficult for me to see. When FF developers start fooling around with colors in the FF browser they need to tread lightly and be aware of all accessibility problems their users may have. Where accessibility is concerned, one size doesn't fit all. Some people have problems with white backgrounds and others, like myself, have problems reading screens with black backgrounds. One simply MUST be aware of sight problems in users. P.S. I tried uploading photos of the black backgrounds in question but the upload wheel just kept spinning. The photo size was within accepted parameter. Also, I tried to check the box "Email me when someone answers the thread" but that wouldnt work either.

All Replies (10)

more options

Type about:addons<enter> in the address box to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance or Themes. Then select Default or System theme — auto. Now restart Firefox.

Helpful?

more options

hardlaceroses said

The browser screen was black and I did that "about:config" thing and toggled the "browser.proton.enabled" to False which converted the background of the browser to back to white but all the other drop down menus are still black. The bookmark toolbar menu is black, the background of the hamburger menu is black, and the "customize menu" background is black. These areas are now difficult for me to see.

I suggest switching that preference back to true; I'm pretty sure other things will be broken by setting it to false.

Firefox may determine your light/dark preference from two different sources:

(1) Your Firefox theme (toolbar theme) (2) Your Windows theme

If your Firefox theme has white or other light-colored text on the inactive tabs, then right-click context menus will follow with light text on a dark background. As far as I know, there is no setting to bypass that.

If your Firefox theme has light text on the main toolbar, then Firefox will follow that scheme on built-in pages. Before Firefox 95, Firefox looked to your system theme for this. If you don't want to change your toolbar theme, there is a setting to revert this change, or you can specify your preference manually. At some point, we expect it to be added to the main Settings page, but for now, it's through the back door:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(C) Normally that preference has a value of 3 meaning to follow your Firefox toolbar theme. To change that, double-click the preference to display an editing field, and use your preferred value from the list below and then click the blue check mark button to save the change.

  • 0 => Dark background always
  • 1 => Light background always
  • 2 => Follow System theme (default in Firefox 94 and earlier)
  • 3 => Follow toolbar theme (default in Firefox 95+)

Does that work?

Helpful?

more options

I changed this setting to 1 which did work for the homepage but not for anything else. How do I change the background of menus and the history page?

Helpful?

more options

baysailor1 said

I changed this setting to 1 which did work for the homepage but not for anything else. How do I change the background of menus and the history page?

The other areas are linked to the text color on your tabs. If your tabs have light text, Firefox will use white-on-black for the sidebar, menus, and the Library window. You would need to switch to a theme that uses dark text on the tabs. For example:

https://addons.mozilla.org/firefox/addon/firefox-b/

Helpful?

more options

Thank you, everyone, for taking the time to reply to my question. I'm very appreciative.

For whatever reason, after the last Firefox update all the black backgrounds have reverted to white.

I've also decided that Firefox has just become waaaaay too difficult to use and am going back to Chrome. Just logging in and trying to ask a technical question has become a night-marish maze and I simply dont want to deal with this any longer. Sometimes the developers, or whatever the people who up-date Firefox are called, get so carried away at their craft they make on-life harder than it needs to be. In their quest to make things easier they wind up doing exactly the opposite.

Again, thanks to those who have taken time to help me with this question and all others I've had to ask in the past.

Helpful?

more options

I agree. Sometimes it looks like they make changes just to make changes. Not because it makes a better browser. How many good things have been cut from the browser?

Helpful?

more options

I agree. The black backgrounds are awful and I have trouble seeing in them as well. Guess I'm moving to Chrome also. When Firefox gets back to the way it used to be...user friendly, if I'm still alive that is, maybe I'll come back. Between the black screens and not being able to fill in forms, I've had it.

Helpful?

more options

I'll do a brief update post:

What is happening in Firefox 96

Firefox 96 harmonizes more parts of Firefox with your toolbar theme, and in particular the text color on your tabs:

  • light/white tab text triggers Firefox to use a dark background on menus, the sidebar, the Library window, and various built-in pages
  • dark/black tab text triggers Firefox to use a light background on menus, the sidebar, the Library window, and various built-in pages

We can all hope there is a setting to decouple your browser theme from your toolbar theme someday, but for now...

What to do about this now

(1) Consider a change to your toolbar theme

The fastest workaround for now is to change your Firefox theme to one that uses dark text. By dark text I mean, for example, the built-in Light theme, or an add-on theme with black or dark text on the tabs. That doesn't need to be blinding, it can have a lighter background color. As examples:

More info on themes: Use themes to change the look of Firefox

(2) For people who can't part with their toolbar theme

As mentioned earlier, this is a partial workaround for the built-in pages, and for websites that have light/dark responsive themes. This is through the back door for now:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

What about other aspects of the UI?

For the sidebar, menus, and toolbar drop-down panels, there is an unofficial, community-supported option, which is to override the built-in styles using your own style rules in a userChrome.css file. I think people are still pondering how to do that efficiently, and perhaps you aren't that into hacking your browser anyway.

Helpful?

more options

All I did was to refresh Firefox and everything went back to normal, to a degree. I had to reinstall my add-on them. Otherwise, I'm happy.

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.


Look on your desktop. Do you see a folder called; Old Firefox? Look inside. Look for the folder with the latest creation date.

https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible


https://support.mozilla.org/en-US/kb/recover-user-data-missing-after-firefox-update

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.