Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF upgraded to 56.0 and now ebay images do not display.

  • 2 replies
  • 2 have this problem
  • 133 views
  • Last reply by ajchicago

more options

All images in the ebay search results page and watch list, etc. do not display, yet above the search results there is a jpg image displaying fine. This happened right after firefox installed updates today. I refreshed FF... no change. I back leveled FF.... no change. I read a tip about holding shift while refreshing page.... voila! Back to normal. Reinstalled 56.0.... back to no images and shift/reload does nothing. Load Images was set to Default and I changed it to Allow on the ebay tab.

All images in the ebay search results page and watch list, etc. do not display, yet above the search results there is a jpg image displaying fine. This happened right after firefox installed updates today. I refreshed FF... no change. I back leveled FF.... no change. I read a tip about holding shift while refreshing page.... voila! Back to normal. Reinstalled 56.0.... back to no images and shift/reload does nothing. Load Images was set to Default and I changed it to Allow on the ebay tab.

Chosen solution

Hi ajchicago, many reports of this in recent hours. If you click this link to a random eBay product photo:

https://i.ebayimg.com/images/g/ZhgAAOSwOfBZ3X-S/s-l1600.jpg

Do you get this error:

An error occurred during a connection to i.ebayimg.com. Invalid OCSP signing certificate in OCSP response. Error code: SEC_ERROR_OCSP_INVALID_SIGNING_CERT

If so, that's why the loading of embedded images is silently failing. It seems to be affecting a number of sites that use the Akamai Content Distribution Network. I don't know how soon it will be cleared up.

As a temporary workaround, you can disable OCSP "stapling." With that change, instead of Firefox expecting sites to provide an OCSP certificate -- a verification that its certificate has not been revoked -- Firefox will query the service provider that signed the certificate. This is good for security but not the best arrangement for privacy, because the service provider knows a computer at your IP address is checking out that site. So after you finish using eBay, you can switch the setting back, or you could use a different browser for the time being.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste ocsp and pause while the list is filtered

(3) Double-click the security.ssl.enable_ocsp_stapling preference to switch the value from true to false

Success?

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Hi ajchicago, many reports of this in recent hours. If you click this link to a random eBay product photo:

https://i.ebayimg.com/images/g/ZhgAAOSwOfBZ3X-S/s-l1600.jpg

Do you get this error:

An error occurred during a connection to i.ebayimg.com. Invalid OCSP signing certificate in OCSP response. Error code: SEC_ERROR_OCSP_INVALID_SIGNING_CERT

If so, that's why the loading of embedded images is silently failing. It seems to be affecting a number of sites that use the Akamai Content Distribution Network. I don't know how soon it will be cleared up.

As a temporary workaround, you can disable OCSP "stapling." With that change, instead of Firefox expecting sites to provide an OCSP certificate -- a verification that its certificate has not been revoked -- Firefox will query the service provider that signed the certificate. This is good for security but not the best arrangement for privacy, because the service provider knows a computer at your IP address is checking out that site. So after you finish using eBay, you can switch the setting back, or you could use a different browser for the time being.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste ocsp and pause while the list is filtered

(3) Double-click the security.ssl.enable_ocsp_stapling preference to switch the value from true to false

Success?

more options

Changing OCSP worked. Thanks! What the heck happened? Someone getting fired? Lol. Thanks, again. Glad I posted! :)