Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Blank screens, logins do not work

  • 11 uphendule
  • 0 zinale nkinga
  • 7 views
  • Igcine ukuphendulwa ngu bkoopers

more options

I have been using Mozilla Firefox for years. I am using the latest version (121.0 (64-bit)). Suddenly today, several websites result in a blank screen (startme and nextdoor) and other pages will not let me login (Citi, Edelman Financial Engines). I tried deleting the cookies and site data and history but it did not help and might have made it worse. When I tried to login to Mozilla support, it says I need to enable cookies and will not let me login. When I go to "Settings-Privacy & Security", it is set to "Standard" which is supposed to include allowing cookies. If there is another place to enable cookies, I do not know where that is.

If I use Microsoft Edge, all the webpages work normally. I had to post this message using Edge because I cannot login to Mozilla using Firefox.

I have many bookmarks saved so I hope whatever the solution is will not lose them.

Thanks to anybody who can help me fix this problem

I have been using Mozilla Firefox for years. I am using the latest version (121.0 (64-bit)). Suddenly today, several websites result in a blank screen (startme and nextdoor) and other pages will not let me login (Citi, Edelman Financial Engines). I tried deleting the cookies and site data and history but it did not help and might have made it worse. When I tried to login to Mozilla support, it says I need to enable cookies and will not let me login. When I go to "Settings-Privacy & Security", it is set to "Standard" which is supposed to include allowing cookies. If there is another place to enable cookies, I do not know where that is. If I use Microsoft Edge, all the webpages work normally. I had to post this message using Edge because I cannot login to Mozilla using Firefox. I have many bookmarks saved so I hope whatever the solution is will not lose them. Thanks to anybody who can help me fix this problem

All Replies (11)

more options

I just tried going to "about:support" and selected "clear the startup cache" but that did not help. I am using Windows 10.

Helpful?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin), always make sure such extensions do not block content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can check for issues with Enhanced Tracking Protection. Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages like blocked content.

Helpful?

more options

Thank you for your response. I carefully went through everything you listed and nothing helps.

The only Extensions I have enabled are: RoboForm Password Manager (which no longer works in Firefox since this problem started today) YouTube Watchmarker

What do you mean by "Default System theme"? The theme enabled says "System theme - auto". Is that the default theme (which I am already using)?

Troubleshoot Mode does not help either.

What else can I do to fix this problem.

Helpful?

more options

I just installed Firefox on a Windows 11 computer that I use for other purposes (it is not my main computer) and I am able to access my start.me page there. The problem is either with Firefox on my Wndows 10 computer or a new incompatibility between Firefox and Windows 10. In either case, I hope somebody can help me.

Helpful?

more options

Did you try to reboot the computer ?

Helpful?

more options

No. You are right. The stranger the problem, the more likely that restarting the computer can make the problem go away. Unfortunately, it takes about 45 minutes to restart my computer (for a variety of reasons) so I try to limit that to the once a month when the monthly Windows update forces me to. The next Windows update should be around Jan. 13th so I will wait until then to do the restart. In the meantime, I will use Edge instead of Firefox. I will update this webpage with the results (either way) after the restart.

Helpful?

more options

Sounds that you have more serious problems if it takes forty five minutes to boot the computer. Aren't you able to fix this or take this to a Windows oriented forum ?

Does the computer start faster if you coot the computer in Windows Safe Mode with network support ?

Helpful?

more options

I have 10 hard drives, 4 printers and a document scanner connected. I cannot restart the computer because it will freeze at the Dell logo after the restart so I have to power it off and then back on and then it works. I suspect there is a power surge at the restart from all the equipment that exceeds the power supply limit that is causing that to happen which fortunately does not happen from a power on (only from a restart). I have 28 icons in the System Tray whose software has to load so it takes time. Microsoft support for Windows 10 ends on Oct 25, 2025 so I will have to replace the computer then. I do not look forward to that effort so I am waiting until I am forced to do it.

Helpful?

more options

I restarted my computer and it only took 30 minutes including installing Windows updates.

Unfortunately, restarting the computer did not fix the Firefox problem. I still get the blank white screens at start.me and nextdoor and the Citi login screen does not fully load.

The start.me technical support had me open a private window in Firefox and then go to the start.me webpage and that works.

Does that give you any clue regarding what the problem and solution is?

I backed up my bookmarks. Should I uninstall and re-install Firefox or do you have something else to try?

Helpful?

more options

Does it still happen in a new profile (without signing into sync account)? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Helpful?

more options

After restarting the computer due to a pending Windows update, the Windows Update screen showed there were still 4 pending updates and the "OS build" had not advanced after the update that was just done. As I previously stated, after the restart, I still had the problem with Firefox. I did another computer restart and another Windows update was processed. I still had the Firefox problem. The Windows Update screen showed there were still 2 (down from 4) pending updates and the "OS build" still had not advanced. I still had the Firefox problem. I did another computer restart and another Windows update was processed. The "OS build" now advanced from 19045.3803 to 19045.3930. I tried Firefox and the problem was gone! I was able to display the start.me and nextdoor webpages and I could login to Citi. Another problem that I had was with a Firefox add-on called "Youtube Watchmarker". It keeps a database of what YouTube videos you have watched and displays "watched" on the screen for the ones you watched. That was not working either. Now it is working.

In conclusion, miraculously, this annoying problem is gone! It appears to have been some kind of Windows corruption problem that got cleared with the last Windows update. Do you have any theories on this before I close this issue?

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.