Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Pages I use every day no longer loading today. Was there an update in the last 24 hours?

  • 4 uphendule
  • 0 zinale nkinga
  • 15 views
  • Igcine ukuphendulwa ngu Paul

more options

On Thursday the pages I have used every day for years worked fine. Today pages like Ancestry.com, familysearch.org, facebook, twitter. None are loading. Was there an update that happened since Thursday? How can I go back to the previous version that worked perfectly? I did check and my system says I'm using the most current version Win10 computer (2 years old if it matters).

On Thursday the pages I have used every day for years worked fine. Today pages like Ancestry.com, familysearch.org, facebook, twitter. None are loading. Was there an update that happened since Thursday? How can I go back to the previous version that worked perfectly? I did check and my system says I'm using the most current version Win10 computer (2 years old if it matters).

Isisombululo esikhethiwe

If you have the AdBlocker Ultimate extension extension then this is likely a problem with this extension as there have been several reports.

  • 1847380 - Adblocker Ultimate preventing pages from displaying correctly

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Show us the issue, the sites work for me. see screenshot Did you try with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

more options

Isisombululo Esikhethiwe

If you have the AdBlocker Ultimate extension extension then this is likely a problem with this extension as there have been several reports.

  • 1847380 - Adblocker Ultimate preventing pages from displaying correctly

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Thank you both for the help. It was good confirmation that all loaded in Safe Mode. And I have now uninstalled Adblocker Ultimate. I really appreciate your time. Thank you.

more options

Hi

I understand that we may have a fix for this problem.

  1. Open AdBlocker Ultimate from the toolbar icon and select Settings.
  2. Next, select the Filters tab in the page that opens and turn off the Security option.
  3. Close the page and then repeat the process, but turning the Security option on.

Does this help fix the issue?