Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Logging In to a site

more options

If I go to https://media.telstra.com.au/home.mobile.android.html using Firefox and then click on the "Webmail" button, I'm taken to https://email.telstra.com/login from which I am unable to log-in.

However, if I do the same using Safari as a browser, I'm taken to a page entitled myid.telstra.com (with a lock symbol in front of it), from which I CAN log-in.

Can anyone offer an explanation. Note, this situation with Firefoix kind of happened overnight some period ago - I had been successfully logging in using Firefox for months/years befoe hand.

If I go to https://media.telstra.com.au/home.mobile.android.html using Firefox and then click on the "Webmail" button, I'm taken to https://email.telstra.com/login from which I am unable to log-in. However, if I do the same using Safari as a browser, I'm taken to a page entitled myid.telstra.com (with a lock symbol in front of it), from which I CAN log-in. Can anyone offer an explanation. Note, this situation with Firefoix kind of happened overnight some period ago - I had been successfully logging in using Firefox for months/years befoe hand.

Isisombululo esikhethiwe

Thanks guys,

clearing cache and cookies seems to have done the job.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (3)

more options

Hey there! It seems like you're having a little trouble with logging in to a site using Firefox, huh? No worries, we've got your back. So, the situation you described is a bit puzzling, especially if it used to work smoothly before. Sometimes these things can happen due to browser settings or updates. Here's a friendly suggestion to try: Let's start by clearing your browser cache and cookies in Firefox. That might help refresh your connection to the site. Also, make sure you're using the latest version of Firefox. If the issue persists, you might want to disable any browser extensions temporarily to see if they're causing any conflicts. And hey, if Safari works fine, it's always good to have a backup, right? Give these steps a shot, and hopefully, you'll be back to smoothly logging in. If not, don't hesitate to drop a line here again. We're here to help you out!

more options

Does it still happen in Troubleshoot Mode?

more options

Isisombululo Esikhethiwe

Thanks guys,

clearing cache and cookies seems to have done the job.