Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Lags While Typing After Last Update

  • 2 uphendule
  • 0 zinale nkinga
  • 27 views
  • Igcine ukuphendulwa ngu Tyr

more options

Long story short, it's in the title. After the most-recent update, Firefox has been hanging whenever I type, and I'm right in the middle of typing a novel. The CPU usage spikes, according to the Firefox Task Manager, to 300% or MORE just from typing a few words. Even right now, typing this, the screen is sentences behind where I am in my typing. Took an entire minute for the page to catch up. On a single paragraph.

The hanging/lag does not occur when I navigate between pages, stream videos on Youtube or Netflix, or other things which should be about 100x more resource-intensive than typing a few sentences. And yet, that's all that does it.

There are no problems with lag when using Chrome, Discord, or other internet-based programs for typing. There are some issues with my word processor, Open Office Writer, but only when Firefox is open and running too, even though the two don't interact, to my knowledge.

I have followed every step on this page: https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding This page: https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems And this page: https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-or-cpu-resources beyond upgrading my computer, because it is absolutely ridiculous to consider doing that given the circumstances. It's only Firefox having the problem, after all.

In addition, I have reinstalled my keyboard driver, turned off cursor highlighting (it wasn't on, but I enabled it and disabled it again, just in case), and removed any delay in repeat keys in the keyboard config. No difference.

Honestly, I don't know that there's a community-based solution for this, but I'm willing to be wrong about that. I just want to make certain someone more official than myself is aware of the problem.

Thanks in advance, -Tyr

Long story short, it's in the title. After the most-recent update, Firefox has been hanging whenever I type, and I'm right in the middle of typing a novel. The CPU usage spikes, according to the Firefox Task Manager, to 300% or MORE just from typing a few words. Even right now, typing this, the screen is sentences behind where I am in my typing. Took an entire minute for the page to catch up. On a single paragraph. The hanging/lag does not occur when I navigate between pages, stream videos on Youtube or Netflix, or other things which should be about 100x more resource-intensive than typing a few sentences. And yet, that's all that does it. There are no problems with lag when using Chrome, Discord, or other internet-based programs for typing. There are some issues with my word processor, Open Office Writer, but only when Firefox is open and running too, even though the two don't interact, to my knowledge. I have followed every step on this page: https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding This page: https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems And this page: https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-or-cpu-resources beyond upgrading my computer, because it is absolutely ridiculous to consider doing that given the circumstances. It's only Firefox having the problem, after all. In addition, I have reinstalled my keyboard driver, turned off cursor highlighting (it wasn't on, but I enabled it and disabled it again, just in case), and removed any delay in repeat keys in the keyboard config. No difference. Honestly, I don't know that there's a community-based solution for this, but I'm willing to be wrong about that. I just want to make certain someone more official than myself is aware of the problem. Thanks in advance, -Tyr

Isisombululo esikhethiwe

Try to enter about:config in the URL bar and change accessibility.force_disabled to 1 then restart.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (2)

more options

Isisombululo Esikhethiwe

Try to enter about:config in the URL bar and change accessibility.force_disabled to 1 then restart.

Helpful?

more options

TyDraniu said

Try to enter about:config in the URL bar and change accessibility.force_disabled to 1 then restart.

This has significantly improved the performance. It's still a bit high on CPU usage, but I think that's probably just me noticing it now that I'm paying attention, more than anything else.

Is this something that was just recently added or turned on in the recent update? Because it seems so odd for it to randomly start affecting me three days ago otherwise, considering I didn't make other changes to my PC that I'm aware of.

Either way, thank you very much! I am pleased I was wrong about the community answer. :)

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.