Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Accented latin letters incorrectly displaying as cyrillic letters

  • 3 uphendule
  • 1 inale nkinga
  • 12 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hi, Firefox is displaying letters with accents (e.g. letters from Spanish words) incorrectly as Cyrillic letters. This makes a lot of webpages difficult to read. This does not seem to be happening all the time. Neither does it seem to happen in other apps other than Firefox. I have my preferred languages for displaying webpages in Firefox set as En-GB, en, es-es, in that order. Ditto for my wider system settings. In terms of my wider system keyboards I do have Russian installed, in order of preference this is gb > us > es > ru. I'm wondering if there is anything I can do to ensure Spanish and other Latin letters display correctly?

Hi, Firefox is displaying letters with accents (e.g. letters from Spanish words) incorrectly as Cyrillic letters. This makes a lot of webpages difficult to read. This does not seem to be happening all the time. Neither does it seem to happen in other apps other than Firefox. I have my preferred languages for displaying webpages in Firefox set as En-GB, en, es-es, in that order. Ditto for my wider system settings. In terms of my wider system keyboards I do have Russian installed, in order of preference this is gb > us > es > ru. I'm wondering if there is anything I can do to ensure Spanish and other Latin letters display correctly?

All Replies (3)

more options

For example, I'm experiencing this on this page: https://m.interglot.com/fr/en/%C3%A9tions but not on this page: https://en.wiktionary.org/wiki/%C3%A9tions with the accented e

more options

The accented e is correctly displayed in my browser on the first page you mention. You could try starting in troubleshoot mode. https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

more options

That is probably a problem with the font that is used. The page that isn't working uses font-family: "Helvetica Neue",Helvetica,Arial,sans-serif; The Wikipedia page uses font-family: sans-serif;

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.