Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to block automatic loading and opening pdf files in browser

  • 4 uphendule
  • 1 inale nkinga
  • 4668 views
  • Igcine ukuphendulwa ngu nabaC

more options

It seems like something has changed recently, I don't remember having such problem before. As you can see on one of my pictures I have browser settings changed to always ask what to do with every file extension, yet encountering link to pdf file it loaded automaticly in special frame instead of showing just link to it. I included pictures of this frame, settings and another screenshot of the same website in Opera browser with similar settings where nothing loads itself.

Link to the problematic comment with auto-loading pdf: https://kodluch.wordpress.com/2021/09/30/30-09-2021-syria-2187-dzien-sprzatania-swiata/#comment-115906

Is there any way to block such pdf-frames in current version of Firefox?

Martin

It seems like something has changed recently, I don't remember having such problem before. As you can see on one of my pictures I have browser settings changed to always ask what to do with every file extension, yet encountering link to pdf file it loaded automaticly in special frame instead of showing just link to it. I included pictures of this frame, settings and another screenshot of the same website in Opera browser with similar settings where nothing loads itself. Link to the problematic comment with auto-loading pdf: https://kodluch.wordpress.com/2021/09/30/30-09-2021-syria-2187-dzien-sprzatania-swiata/#comment-115906 Is there any way to block such pdf-frames in current version of Firefox? Martin
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

You may have encountered the issue(s) mentioned here: https://bugzilla.mozilla.org/show_bug.cgi?id=1725921 https://support.mozilla.org/en-US/questions/1347907#answer-1436949 https://support.mozilla.org/en-US/questions/1349133#answer-1439707 https://bugzilla.mozilla.org/show_bug.cgi?id=1726501

In my case it affects local pdf files only. I have made the following true in about:config. It means you can't use Firefox as a pdf viewer but that's no loss in my view. pdfjs.disabled

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (4)

more options

Isisombululo Esikhethiwe

You may have encountered the issue(s) mentioned here: https://bugzilla.mozilla.org/show_bug.cgi?id=1725921 https://support.mozilla.org/en-US/questions/1347907#answer-1436949 https://support.mozilla.org/en-US/questions/1349133#answer-1439707 https://bugzilla.mozilla.org/show_bug.cgi?id=1726501

In my case it affects local pdf files only. I have made the following true in about:config. It means you can't use Firefox as a pdf viewer but that's no loss in my view. pdfjs.disabled

more options

Note that this happens if, like in the case, the PDF file is send as application/pdf.

more options

Hmm, this seems to be a feature of the wordpress.com site: https://wordpress.com/support/embedding-a-pdf-file/

However, I am seeing a normal link, so maybe first time visitors don't get the embedded PDF treatment??

more options

Thx for the answers. Seems like that auto-embedding pdfs is a wordpress feature as jscher2000 said. Comment poster on wordpress fixed it by adding dot in the beginning of the link that's why it doesn't load itself anymore. Example embedding from wordpress support shows the same frame as in original post - https://wordpress.com/support/embedding-a-pdf-file/ and TerryN21 method with blocking pdfs in config worked well! Now I see "click to access" just like in Opera and clicking it downloads file. :)

Problem solved, thx alot!