Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I make the font smaller in the bookmarks dropdown in Firefox 89?

  • 15 uphendule
  • 1 inale nkinga
  • 137 views
  • Igcine ukuphendulwa ngu Figureguy

more options

Good afternoon. My Firefox has been updated to the new version but I noticed that the font size in my bookmarks dropdown menu has increased. I would prefer to make it smaller as it used to all fit in one column without the need to scroll. Could someone tell me how, or if this can be done with the new version? Thanks and hope to hear back soon.

Isisombululo esikhethiwe

**THIS SOLUTION WAS FOR FIREFOX 89-90 ONLY**

For Firefox 91+, you can use the community-supported (unofficial) workaround of creating a userChrome.css file. More info in this post: https://support.mozilla.org/en-US/questions/1337842#answer-1416083 (if you want even less padding than Firefox 88, reduce 4px to a lower value such as 2px).


Hi, this is easier -- a temporary preference that may provide partial relief:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.proton.contextmenus.enabled and pause while the list is filtered

(3) Double-click the preference to switch between true (new style) and false (old style)

In my test, the Bookmarks menu on the optional top Menu Bar was messed up in the existing window, but looked okay in a new window.

If that doesn't help enough, you still have the option to use custom style rules in a userChrome.css file.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (15)

more options

I think it's more about adding space between the lines. This isn't the first time they messed that one up either...

Helpful?

more options

Currently, I don't think there is any built-in way to modify the spacing of menu items (to make them closer together). Actually, see the temporary workaround here: answer-1416715

One option is the community-supported workaround of restyling the interface by creating a userChrome.css file. It's a little bit of a project, so make sure you set aside 10 quiet minutes to work through it.

(For anyone who already has a userChrome.css file set up, you just need to add the rule under (A) to your file.)

(A) Select and copy the following style rule code

/*** Tighten up drop-down/context/popup menu spacing (updated 9/7/2021) ***/

menupopup:not(.in-menulist) > menuitem, 
menupopup:not(.in-menulist) > menu {
  padding-block: 2px !important;
}
:root {
  --arrowpanel-menuitem-padding: 4px 8px !important;
}


Some users consider that 4 pixels of space above and below items is still too spacious and prefer a lower value. The third attached screenshot show the difference between 2px, 3px, and 4px. (The 8px refers to the left side and right side, so no need to change that part.)

(B) Generate and download a userChrome.css file

Open the following page and paste the above rules into the editor, replacing the sample rule:

https://www.userchrome.org/download-userchrome-css.html

Then click "Generate CSS File" and save the userChrome.css file to your computer. (See first attached screenshot)

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See second attached screenshot)

Minimize that file browser window for later reference.

(C) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(D) Move the userChrome.css file you generated in Step B into the chrome folder you created in Step C

(E) Set Firefox to look for userChrome.css at startup -- see step #6 in the above article.

The next time you exit Firefox and start it up again, it should discover that file and apply the rules.

Success? I have a screenshot showing the expected difference here: https://www.userchrome.org/firefox-89-styling-proton-ui.html#menuspacing

I suggest bookmarking any thread you get userChrome.css code from for future reference (in case the rule stops working).

Okulungisiwe ngu jscher2000

Helpful?

more options

Thank you so much for your suggestion but I believe that is way beyond my comfort zone. I don't want to mess up my Firefox but figured their would be some way to change the bookmarks to be closer. I'm sure an add on will come out eventually but I would have expected an easier way in the settings or something that could be accessed through about:config.

Helpful?

more options

Isisombululo Esikhethiwe

**THIS SOLUTION WAS FOR FIREFOX 89-90 ONLY**

For Firefox 91+, you can use the community-supported (unofficial) workaround of creating a userChrome.css file. More info in this post: https://support.mozilla.org/en-US/questions/1337842#answer-1416083 (if you want even less padding than Firefox 88, reduce 4px to a lower value such as 2px).


Hi, this is easier -- a temporary preference that may provide partial relief:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.proton.contextmenus.enabled and pause while the list is filtered

(3) Double-click the preference to switch between true (new style) and false (old style)

In my test, the Bookmarks menu on the optional top Menu Bar was messed up in the existing window, but looked okay in a new window.

If that doesn't help enough, you still have the option to use custom style rules in a userChrome.css file.

Okulungisiwe ngu jscher2000

Helpful?

more options

I believe it works. After tweeking the setting I closed and re-opened Firefox and now the bookmarks drop down looks exactly like it used to. Perfect. Thank you so much for your help however I'm sure Mozilla will do something to muck it up again.

Helpful?

more options

Please restore our ability to customize density. I have carpal tunnel symptoms and having to move the mouse or scroll further than previously was necessary through these widely spaced menus is a problem. I see there is a cumbersome workaround, but why make it so difficult. Mozilla is getting more and more like Microsoft in giving (forcing on) us “features” we don’t want. That is why many of us switched from IE to Firefox many years ago.

Please give us more options, not fewer options, to customize the browser. Otherwise you are going to lose many of us to Edge or Chrome.

Thank you.

Helpful?

more options

Hi BIlly, did you try the temporary workaround?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.proton.contextmenus.enabled and pause while the list is filtered

(3) Double-click the preference to switch between true (new style) and false (old style)

In my test, the Bookmarks menu on the optional top Menu Bar was messed up in the existing window, but looked okay in a new window.

Helpful?

more options

That didn't work for me but changing browser.proton.enabled to false did the trick.

Helpful?

more options

Hi jscher 2000,

Finally plucked up the courage to follow your suggestion on creating the userchrome.css file and it worked like an absolute dream! Thank you so very much for your help - I shall raise a glass to you tonight!

Helpful?

more options

the "temporary workaround" worked! Why do you say it's "temporary?" Will it revert back to the original configuration when I restart? Thanks again for the help.

Helpful?

more options

The second solution from jscher2000 I marked as the chosen solution. Thanks you jscher2000 for taking the time to answer and help me. Rather than go into the files the about:config instructions he gave were much simpler and worked great. I implemented it on 6/2 and it has still held. Unless there is an issue and I update this is exactly what I was looking for and how I wanted the dropdown to look.

Helpful?

more options

rhimea said

the "temporary workaround" worked! Why do you say it's "temporary?"

In some future version, the old code will be removed and the preference will not do anything any more. We don't know when that will be, but no sooner than next month.

Helpful?

more options

Good afternoon. Since Firefox updated to v. 91 this morning the bookmarks dropdown has gone back to the larger font. Is there a way to change it now to the smaller font? Also can someone tell me how to change the color of the dropdown menus? When the update happened it changed to white font on black background but I want to go back to black font on white background. Thanks in advance for any help.

Helpful?

more options

Figureguy said

Good afternoon. Since Firefox updated to v. 91 this morning the bookmarks dropdown has gone back to the larger font. Is there a way to change it now to the smaller font? Also can someone tell me how to change the color of the dropdown menus? When the update happened it changed to white font on black background but I want to go back to black font on white background. Thanks in advance for any help.

Hi, the "temporary" preferences are gone now. I updated the solution post with a note on that. So at this point, you need to use the community-supported (unofficial) method, a userChrome.css file.

I think changing the spacing solves what most users are objecting too, without making the text itself larger or smaller, so I suggest trying that first. Of course, it also is possible to change the text size with different rules (not included in the earlier reply).

Regarding the color, Firefox flips the menus between dark theme and light theme based on the text color of the inactive/background tabs. As the color gets lighter, at some point, Firefox flips the theming. You can override that in your userChrome.css file. For example, try adding this:

/*** Color the menus (black on white) ***/
menupopup {
  --menu-color: #000 !important;
  --menu-disabled-color: #555 !important;
  --menu-background-color: #fafafa !important;
  --menu-border-color: #333 !important;
  --menuitem-hover-background-color: #ddd !important;
}

Helpful?

more options

Not too sure of my ability to create the file plus a little nervous in general about messing too much with the PC. I had an issue pop up last week that I had no idea what happened but after a lengthy support call to Dell all that was left was the nuclear option. Factory Reset. I always have a backup on hand but there was still a bit to do in order to get it running the same and have everything set the way it was (settings, programs, schedules, etc.) I do worry about trying something I honestly do not have much knowledge about but also some trepidation with. I wish the initial true/false change that worked before did again.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.