Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to disable ssl redirect in Firefox

  • 1 baphendule
  • 1 inale nkinga
  • 31 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hi,

Im struggling like hours on getting a http connection to a private webservice of mine... Firefox always redirect me to https://example.com instead of http://example.com.

I tried following solutions: - delete whole cache - Start Firefox in Safe mode - removing all extensions - setting this in about:config:

   security.insecure_field_warning.contextual.enabled = false
   security.certerrors.permanentOverride = false
   network.stricttransportsecurity.preloadlist = false
   security.enterprise_roots.enabled = true 
   browser.urlbar.autoFill to false in about:config.
   browser.cache.check_doc_frequency from 3 to 1. 
   urlbar.autofill false
   browser.urlbar.trimURLs false

- restarting firefox - restarting computer

And still this damn brower redirects me to a https site!!!!!!!!!

Searching for a solution since 4 hours. Please help me!

Hi, Im struggling like hours on getting a http connection to a private webservice of mine... Firefox always redirect me to https://example.com instead of http://example.com. I tried following solutions: - delete whole cache - Start Firefox in Safe mode - removing all extensions - setting this in about:config: security.insecure_field_warning.contextual.enabled = false security.certerrors.permanentOverride = false network.stricttransportsecurity.preloadlist = false security.enterprise_roots.enabled = true browser.urlbar.autoFill to false in about:config. browser.cache.check_doc_frequency from 3 to 1. urlbar.autofill false browser.urlbar.trimURLs false - restarting firefox - restarting computer And still this damn brower redirects me to a https site!!!!!!!!! Searching for a solution since 4 hours. Please help me!

All Replies (1)

more options

You would have to check the SiteSecurityServiceState.txt file in the profile folder for references about this host (domain) and remove corresponding lines. That should work unless this domain is on the HSTS preload list.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.