X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Ctrl + right arrow doesn't work in developer console to move to next word

Kuphostiwe

With a recent update, when working in the developer console, ctrl + right arrow does not move forward one word. Ctrl + left arrow still works.

I reviewed https://developer.mozilla.org/en-US/docs/Tools/Keyboard_shortcuts but couldn't find any reference.

I use this automatically and am really missing it. Why would jumping left by one word still work - but not right?

To reproduce:

1. In the developer tools console, enter "one two three". 2. Now use ctrl+left arrow. The cursor jumps to the start of each word going back to the start of the line. 3. Now use ctrl+right arrow. The cursor doesn't move. 4. Try the same in Notepad. The cursor moves forward one word with ctrl+right arrow.

Using 66.05

With a recent update, when working in the developer console, ctrl + right arrow does not move forward one word. Ctrl + left arrow still works. I reviewed https://developer.mozilla.org/en-US/docs/Tools/Keyboard_shortcuts but couldn't find any reference. I use this automatically and am really missing it. Why would jumping left by one word still work - but not right? To reproduce: 1. In the developer tools console, enter "one two three". 2. Now use ctrl+left arrow. The cursor jumps to the start of each word going back to the start of the line. 3. Now use ctrl+right arrow. The cursor doesn't move. 4. Try the same in Notepad. The cursor moves forward one word with ctrl+right arrow. Using 66.05
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Eminye Imininingwane

Wesley Branton
  • Top 10 Contributor
543 izisombululo 4695 izimpendulo
Kuphostiwe

This does appear to be a bug in Firefox. I've filed a bug report on your behalf (see bug #1552935) so that the developers can fix the issue.

This does appear to be a bug in Firefox. I've filed a bug report on your behalf ([https://bugzilla.mozilla.org/show_bug.cgi?id=1552935 see bug #1552935]) so that the developers can fix the issue.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17217 izisombululo 155544 izimpendulo
Kuphostiwe

For what it is worth, this does work for me in Firefox 67.0 when tested. I think that Firefox 67 is ready to be released, so you can try to update tomorrow to see whether this helps.

For what it is worth, this does work for me in Firefox 67.0 when tested. I think that Firefox 67 is ready to be released, so you can try to update tomorrow to see whether this helps.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Wesley Branton
  • Top 10 Contributor
543 izisombululo 4695 izimpendulo
Kuphostiwe

cor-el said

For what it is worth, this does work for me in Firefox 67.0 when tested.

Doesn't work for me in Firefox 68.

''cor-el [[#answer-1223633|said]]'' <blockquote>For what it is worth, this does work for me in Firefox 67.0 when tested.</blockquote> Doesn't work for me in Firefox 68.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17217 izisombululo 155544 izimpendulo
Kuphostiwe

I'm on Linux, so maybe this is a Windows issue.

Does this also happen in the Scratchpad or on the search bar or the filter bar?

I'm on Linux, so maybe this is a Windows issue. Does this also happen in the Scratchpad or on the search bar or the filter bar?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17217 izisombululo 155544 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

OP here.

I'm using Windows 10.

Problem still evident in Safe Mode with build 66; then did an update to 67 and the problem is still there.

The search box in developer tools, as well as CSS filter box all operate correctly - ctrl+right arrow moves forward one word. Assuming that Scratchpad is when "Edit as HTML" is chosen - this works OK as well.

OP here. I'm using Windows 10. Problem still evident in Safe Mode with build 66; then did an update to 67 and the problem is still there. The search box in developer tools, as well as CSS filter box all operate correctly - ctrl+right arrow moves forward one word. Assuming that Scratchpad is when "Edit as HTML" is chosen - this works OK as well.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.